Bug 839199 - [RHEVM] [backend] [Setup Host Networks] it is possible to assign same IP on two interfaces for same host
[RHEVM] [backend] [Setup Host Networks] it is possible to assign same IP on t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Muli Salem
Martin Pavlik
network
:
: 823824 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 04:01 EDT by Martin Pavlik
Modified: 2016-02-10 14:53 EST (History)
8 users (show)

See Also:
Fixed In Version: si14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:06:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (682.84 KB, application/x-gzip)
2012-07-11 04:01 EDT, Martin Pavlik
no flags Details
duplicate IP (151.83 KB, image/png)
2012-07-11 04:02 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-07-11 04:01:35 EDT
Created attachment 597489 [details]
vdsm.log + engine.log

Description of problem:  it is possible to assign same IP on two interfaces for same host

in this scenario I assigned duplicate IP for 2 interfaces at the same time, but bug reproduces also if you do it one by one

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.1.0-5.el6ev 

How reproducible:
100%

Steps to Reproduce:
you need host with at least 2 NICs, 3NICs is better
1. Create 2 logical networks
2. Hosts -> your host -> Network interfaces -> setup host networks
   a) drag first logical network (NET1) to eth1 
   b) drag second logical network (NET2) to eth2 
   c) click on pencil icon of NET1 -> assign static IP -> click OK
   d) click on pencil icon of NET2 -> assign static IP -> click OK

3. click OK

Actual results:
same IP assigned on two interfaces for the same host

Expected results:
it should be not possible to assign same IP on two interfaces for the same host

Additional info:
Thread-140::DEBUG::2012-07-11 09:46:03,700::BindingXMLRPC::864::vds::(wrapper) client [10.34.63.65]::call setupNetworks with ({'NET2': {'nic': 'p1p1', 'netmask': '255.255.255.0', 'ipaddr': '192.168.11.11', 'bridged': 'true'}, 'NET1': {'nic': 'em2', 'netmask': '255.255.255.0', 'ipaddr': '192.168.11.11', 'gateway': '0.0.0.0', 'bridged': 'true'}}, {}, {'connectivityCheck': 'true', 'connectivityTimeout': 60000}) {} flowID [7f5913c3]
Comment 1 Martin Pavlik 2012-07-11 04:02:04 EDT
Created attachment 597490 [details]
duplicate IP
Comment 2 Martin Pavlik 2012-07-11 07:23:36 EDT
*** Bug 823824 has been marked as a duplicate of this bug. ***
Comment 3 Muli Salem 2012-07-29 04:01:26 EDT
Proposed fix in:

http://gerrit.ovirt.org/#/c/6695/
Comment 4 Muli Salem 2012-08-05 10:38:38 EDT
Fixed in: e9dd926f4b26adbff3049be21d55618908ae539b

Note You need to log in before you can comment on or make changes to this bug.