Bug 839206 - Multiple segfaults with libresolv-2.15.so
Multiple segfaults with libresolv-2.15.so
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
: 834722 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-11 04:26 EDT by ZiN
Modified: 2016-11-24 11:00 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 09:39:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Syslog messages filtered by sigfault entries (165.87 KB, text/plain)
2012-07-11 04:26 EDT, ZiN
no flags Details
resolv.conf (127 bytes, text/plain)
2012-07-11 04:28 EDT, ZiN
no flags Details
Log messages of strace freshclam (26.36 KB, text/plain)
2012-07-11 04:30 EDT, ZiN
no flags Details

  None (edit)
Description ZiN 2012-07-11 04:26:14 EDT
Created attachment 597500 [details]
Syslog messages filtered by sigfault entries

Description of problem:
Many progams crash with segfault in libresolv-2.15.so
Freshclam, ntp, sendmail, ibus.
I've got also crashes with some win32 instant messenger in wine. The log trace also pointed to libresolv-2.15.so. Skype also sigfaults, but only on one machine that I have, while it runs on another.

Version-Release number of selected component (if applicable):
glibc-2.15-48.fc17.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Programs crash with sigfault

Expected results:
Normal functioning

Additional info:
Comment 1 ZiN 2012-07-11 04:28:27 EDT
Created attachment 597501 [details]
resolv.conf
Comment 2 ZiN 2012-07-11 04:30:01 EDT
Created attachment 597502 [details]
Log messages of strace freshclam
Comment 3 Jeff Law 2012-07-11 09:39:47 EDT
Thanks.  This is a known issue and an update is already in fedora-updates-testing which should resolve this issue (glibc-2.15-51.fc17).

https://admin.fedoraproject.org/updates/glibc-2.15-51.fc17


Please try that build; assuming it fixes your problem, please leave feedback and add karma to the update so that the update will migrate from updates-testing to the official updates repository.
Comment 4 ZiN 2012-07-13 10:15:21 EDT
Yes, this update resolves the problem.
Comment 5 Jeff Law 2012-10-04 14:31:15 EDT
*** Bug 834722 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.