Bug 839599 - FTBFS perl-Hardware-Verilog-Parser-0.13-10.fc18
Summary: FTBFS perl-Hardware-Verilog-Parser-0.13-10.fc18
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Hardware-Verilog-Parser   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chitlesh GOORAH
QA Contact: Fedora Extras Quality Assurance
URL: https://koji.fedoraproject.org/koji/t...
Whiteboard:
Keywords:
: 868513 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-12 12:05 UTC by Petr Pisar
Modified: 2012-11-25 15:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-25 15:29:40 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petr Pisar 2012-07-12 12:05:33 UTC
perl-Hardware-Verilog-Parser-0.13-10.fc18 fails to build in F18:

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.qFYRdO
+ umask 022
+ cd /builddir/build/BUILD
+ cd Hardware-Verilog-Parser-0.13
+ LANG=C
+ export LANG
+ unset DISPLAY
+ ./generate_precompiled_parser.pl
precompiling grammar from file 'PrecompiledParser.pm'
to class PrecompiledParser in module file 'PrecompiledParser.pm'
              Warning: Undefined (sub)rule "block_identifer" used in a
                       production.
                ERROR: Production edge_sensitive_path_declaration for
                       "_alternation_1_of_production_1_of_rule_path_declaratio
                       n" will never be reached (preceding empty production
                       will always match first).
                 Hint: Set $::RD_HINT (or -RD_HINT if you're using "perl -s")
                       for hints on fixing these problems. Use $::RD_HINT = 0
                       to disable this message.
Can't compile bad grammar at ./generate_precompiled_parser.pl line 2755.

Comment 1 Fedora Update System 2012-11-05 14:11:57 UTC
perl-Hardware-Verilog-Parser-0.13-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-Hardware-Verilog-Parser-0.13-12.fc18

Comment 2 Paul Howarth 2012-11-05 14:12:51 UTC
*** Bug 868513 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2012-11-05 22:44:22 UTC
Package perl-Hardware-Verilog-Parser-0.13-12.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Hardware-Verilog-Parser-0.13-12.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17627/perl-Hardware-Verilog-Parser-0.13-12.fc18
then log in and leave karma (feedback).


Note You need to log in before you can comment on or make changes to this bug.