Bug 868513 - perl-Hardware-Verilog-Parser is FTBFS on F18+
Summary: perl-Hardware-Verilog-Parser is FTBFS on F18+
Keywords:
Status: CLOSED DUPLICATE of bug 839599
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Hardware-Verilog-Parser
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chitlesh GOORAH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-10-20 12:39 UTC by Peter Robinson
Modified: 2012-11-05 14:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-05 14:12:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Robinson 2012-10-20 12:39:53 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=4610657

+ cd Hardware-Verilog-Parser-0.13
+ ./generate_precompiled_parser.pl
precompiling grammar from file 'PrecompiledParser.pm'
to class PrecompiledParser in module file 'PrecompiledParser.pm'
              Warning: Undefined (sub)rule "block_identifer" used in a
                       production.
                ERROR: Production edge_sensitive_path_declaration for
                       "_alternation_1_of_production_1_of_rule_path_declaratio
                       n" will never be reached (preceding empty production
                       will always match first).
                 Hint: Set $::RD_HINT (or -RD_HINT if you're using "perl -s")
                       for hints on fixing these problems. Use $::RD_HINT = 0
                       to disable this message.
Can't compile bad grammar at ./generate_precompiled_parser.pl line 2755.

Comment 1 Ankur Sinha (FranciscoD) 2012-11-02 02:55:19 UTC
Hi,

Can this package please be fixed? It causes a breakage when one tries to update to fedora 18 using yum. 

Thanks,
Ankur

Comment 2 Shakthi Kannan 2012-11-02 04:51:52 UTC
From Parse::RecDescent:

"Until version 1.967003 of Parse::RecDescent, parser modules built with Precompile were dependent on Parse::RecDescent. Future Parse::RecDescent releases with different internal implementations would break pre-existing precompiled parsers."

Source: http://search.cpan.org/~jtbraun/Parse-RecDescent-1.967009/lib/Parse/RecDescent.pm

This feature is experimental though. I have asked upstream for a clarification.

Comment 3 Paul Howarth 2012-11-05 14:12:51 UTC

*** This bug has been marked as a duplicate of bug 839599 ***


Note You need to log in before you can comment on or make changes to this bug.