Bug 839718 - install_RHUA.sh script should check that hostname is set before continuing
install_RHUA.sh script should check that hostname is set before continuing
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: James Slagle
Martin Kočí
:
: 834026 (view as bug list)
Depends On:
Blocks: 840016
  Show dependency treegraph
 
Reported: 2012-07-12 12:14 EDT by James Slagle
Modified: 2012-08-24 07:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The install_RHUA.sh and install_CDS.sh scripts did not check if hostname is set which leads to an error during installation if hostname was not set correctly. The scripts have been modified to check if hostname is set before continuing. If hostname is set to localhost.localdomain or localhost, the scripts will stop and report an error.
Story Points: ---
Clone Of:
: 840016 (view as bug list)
Environment:
Last Closed: 2012-08-24 07:55:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Slagle 2012-07-12 12:14:13 EDT
install_RHUA.sh script should check that hostname is set before continuing

if hostname is set to localhost.localdomain or localhost, bail out and report an error.
Comment 1 James Slagle 2012-07-12 12:45:49 EDT
committed to install_RHUA.sh script
Comment 2 James Slagle 2012-07-12 12:46:18 EDT
and the same logic committed to the install_CDS.sh script
Comment 3 James Slagle 2012-07-31 14:05:52 EDT
*** Bug 834026 has been marked as a duplicate of this bug. ***
Comment 4 Martin Kočí 2012-08-03 07:43:08 EDT
checked install_CDS.sh and install_RHUA.sh script for chekcing the hostname issue...
RHEL-6.3-RHUI-2.1-20120801.0-Server-x86_64-DVD1.iso

Issue reproduced against RHEL-6.3-RHUI-2.1-20120705.0-Server-x86_64-DVD1.iso

Moving bug to VERIFIED.
Comment 5 sachua 2012-08-15 00:56:46 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The install_RHUA.sh and install_CDS.sh scripts did not check if hostname is set which leads to an error during installation if hostname was not set correctly. The scripts have been modified to check if hostname is set before continuing. If hostname is set to localhost.localdomain or localhost, the scripts will stop and report an error.
Comment 7 errata-xmlrpc 2012-08-24 07:55:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.