Bug 840016 - install_RHUA.sh script should check that hostname is set before continuing
install_RHUA.sh script should check that hostname is set before continuing
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Documentation (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Julie
Martin Kočí
:
Depends On: 817736 839718
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 09:14 EDT by James Slagle
Modified: 2012-08-24 09:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In Red Hat Update Infrastructure package installation, the value of FQDN must be set before installation. This new update adds a check to the install_RHUA.sh and install_CDS.sh scripts that makes sure that a FQDN has been set on the box before proceeding installation.
Story Points: ---
Clone Of: 839718
Environment:
Last Closed: 2012-08-24 07:55:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Slagle 2012-07-13 09:14:10 EDT
+++ This bug was initially created as a clone of Bug #839718 +++

install_RHUA.sh script should check that hostname is set before continuing

if hostname is set to localhost.localdomain or localhost, bail out and report an error.

--- Additional comment from jslagle@redhat.com on 2012-07-12 12:45:49 EDT ---

committed to install_RHUA.sh script

--- Additional comment from jslagle@redhat.com on 2012-07-12 12:46:18 EDT ---

and the same logic committed to the install_CDS.sh script
Comment 1 James Slagle 2012-07-13 09:17:02 EDT
I added a check to the install_RHUA.sh and install_CDS.sh scripts that makes sure that a FQDN has been set on the box before proceeding.  I think this would be worth adding to the guide.

So, if the hostname is unset and its value is reported as localhost.localdomain or localhost, then users will see this when they try to run these scripts:

Hostname is "localhost.localdomain" and does not appear to be set.
It must be set to a fqdn before continuing installation.
Set the hostname, and then re-run this script.
Comment 3 Martin Kočí 2012-07-26 11:49:11 EDT
There is an important note saying: "If the hostname is unset and its value is reported as localhost.localdomain or localhost, you will see an error message when running the install_RHUA.sh and install_CDS.sh scripts. "
See the procedure 2.2 in chapter 2.3: http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Update_Infrastructure/2.1/html/Installation_Guide/sect-Installation_Guide-Installation_Requirements-Package_Installation.html

Moving bug to VERIFIED.
Comment 4 Shikha 2012-08-16 05:13:32 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In Red Hat Update Infrastructure package installation, the value of FQDN must be set before installation. This new update adds a check to the install_RHUA.sh and install_CDS.sh scripts that makes sure that a FQDN has been set on the box before proceeding installation.
Comment 6 errata-xmlrpc 2012-08-24 07:55:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.