Bug 83972 - redhat-config-time crashes on upgrade system
redhat-config-time crashes on upgrade system
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-date (Show other bugs)
phoebe
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-10 11:39 EST by Harris Landgarten
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-10 15:17:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harris Landgarten 2003-02-10 11:39:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
This is an update of a RH 8 installation. Redhat-config-time worked properly
under rh8.0 and was set for GMT and NTP from time.nist.gov

When the redhat-config-time or redhat-config-date command are run on this
machine after the upgrade to phoebe the command crashes with the following backtrace

[harrisl@d8100 etc]$ sudo redhat-config-time
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 48, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 180, in __init__
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 173, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
socket.herror: (1, 'Unknown host')

Note: ntpd is running properly  as setup under rh8



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. sudo redhat-config-time
2.
3.
    

Actual Results:  [harrisl@d8100 etc]$ sudo redhat-config-time
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 48, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 180, in __init__
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 173, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
socket.herror: (1, 'Unknown host')

Expected Results:  usual time window

Additional info:
Comment 1 Brent Fox 2003-02-10 12:48:39 EST

*** This bug has been marked as a duplicate of 82061 ***
Comment 2 Harris Landgarten 2003-02-10 14:42:47 EST
I am getting this bug with redhat-config-date-1.5.7-6 which I believe was the 
proposed fix.
Comment 3 Brent Fox 2003-02-10 14:45:49 EST
Can you try upgrading to 1.5.9-4 out of Rawhide?
Comment 4 Harris Landgarten 2003-02-10 15:10:04 EST
redhat-config-date-1.5.9-4 from rawhide resolved the problem
Comment 5 Brent Fox 2003-02-10 15:17:11 EST
Ok, good.  I later realized that you were actually having a slightly different
bug than bug #82061, but I knew that I had fixed something like yours in the
past few weeks.  I'm glad to know things are working now.  Closing as 'rawhide'.

Note You need to log in before you can comment on or make changes to this bug.