Bug 839804 - don't display a mount warning when mounting squashfs
don't display a mount warning when mounting squashfs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: livecd-tools (Show other bugs)
6.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Brian Lane
Virtualization Bugs
:
Depends On:
Blocks: 809085 853284
  Show dependency treegraph
 
Reported: 2012-07-12 17:30 EDT by Joey Boggs
Modified: 2013-02-21 08:17 EST (History)
6 users (show)

See Also:
Fixed In Version: livecd-tools-13.4.2
Doc Type: Bug Fix
Doc Text:
Previously an error message was diplayed when using the livecd-tools to mount the read-only squashfs filesyetem of an ISO file. The "ro" option was added to the mount command, and the error message is no longer displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 08:17:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joey Boggs 2012-07-12 17:30:56 EDT
RHEV-H will have a tool used for editing images using underlying imgcreate libraries and a warning message stating "mounting read/write failed, trying read only" is display when mounting the squashfs filesystem in the iso. This patch adds the ro arg to the mount command for squashfs file systems so that warning is no longer displayed

http://git.fedorahosted.org/git/?p=livecd;a=commit;h=51582cd889ab721d09c576008e6b93f2ca26e89c
Comment 9 errata-xmlrpc 2013-02-21 08:17:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0542.html

Note You need to log in before you can comment on or make changes to this bug.