Bug 83998 - metacity fails to do host lookups from the display string
Summary: metacity fails to do host lookups from the display string
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metacity   
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-02-10 21:24 UTC by P Jones
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 18:35:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/hosts file used in problem (441 bytes, text/plain)
2003-02-14 22:00 UTC, P Jones
no flags Details

Description P Jones 2003-02-10 21:24:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
on remote machines with addresses in the address part of the display var,
metacity fails to load.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.enable xdmcp gdm
2.Xnest :2 -query ***MACHINENAME***
3.login 

    

Actual Results:  gnome-session crashed. wm crashed

Expected Results:  normal login

Additional info:

Logging in failsafe (where blip==machinename)
and running metacity by hand I see the error message:
_X11TransSocketINETConnect: not INET hostblip
Window manager error: Unable to open X display blip:2.0

(Then I have to ^C metacity as it loops)

I ran these to make sure that DNS, etc was functional:
$ host blip
blip.internal.datastacks.com has address 10.1.2.6
$ grep blip /etc/hosts
10.1.2.6        blip
$ dig +search blip
...
blip.internal.datastacks.com. 300 IN    A       10.1.2.6
...



When manually setting the display to "10.1.2.6:2.0", it runs Fine.

Comment 1 Havoc Pennington 2003-02-11 14:42:17 UTC
Looks like an Xlib problem to me - does xterm work? or xclock?


Comment 2 Havoc Pennington 2003-02-12 01:01:45 UTC
Please reopen on adding info.

Comment 3 P Jones 2003-02-12 01:24:41 UTC
xterm, mwm, gnome-panel, and nautilus all work.

More looking into it seems that this condition only happens if the name in
address *IS* in /etc/hosts.
In this case, "blip".

Comment 4 Havoc Pennington 2003-02-13 17:45:12 UTC
I really have no initial guess how metacity is different from other apps in this 
area, but will have a look.

Comment 5 Havoc Pennington 2003-02-14 21:24:17 UTC
That error message occurs when gethostbyname() thinks the host is not a TCP/IP 
host; can you attach your /etc/hosts file? I don't know how it would happen or 
how it could be metacity-only.

I tried reproducing the problem with Xnest/xdmcp and it works for me, 
tried both with and without the hostname in /etc/hosts. I am trying with 
the latest beta though, not with 8.0.

Comment 6 P Jones 2003-02-14 22:00:40 UTC
Created attachment 90098 [details]
/etc/hosts file used in problem

Comment 7 Havoc Pennington 2004-05-25 18:56:49 UTC
Please reopen if still present in Fedora Core 2


Note You need to log in before you can comment on or make changes to this bug.