Bug 840114 - [RFE] NUMA aware KSM support in RHEV-M
[RFE] NUMA aware KSM support in RHEV-M
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
unspecified
x86_64 Unspecified
medium Severity medium
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Dudi Maroshi
Artyom
http://www.ovirt.org/NumaAwareKsmSupport
: FutureFeature, Triaged
Depends On: 743643 840113 852657 947944 949244 977627 1098010
Blocks: 767187 801095 832572
  Show dependency treegraph
 
Reported: 2012-07-13 14:53 EDT by Karen Noel
Modified: 2016-03-09 15:27 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Kernel SamePage Merging (KSM) can now be configured to obey or ignore Non-Uniform Memory Access (NUMA) topology constraints in the Red Hat Enterprise Virtualization Manager. KSM can now either merge pages across the whole machine, ignoring NUMA topology, or merge pages only inside NUMA nodes while obeying the NUMA boundaries.
Story Points: ---
Clone Of: 840113
Environment:
Last Closed: 2016-03-09 15:27:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgrinber: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 39777 None None None Never
oVirt gerrit 39783 None None None Never
oVirt gerrit 39864 None None None Never
oVirt gerrit 40129 None None None Never
oVirt gerrit 40130 None None None Never
oVirt gerrit 42376 master MERGED engine: [rest-api] fix indentation for KSM in Cluster mapper Never
oVirt gerrit 42410 master MERGED webadmin: KSM enabled checkbox alway start unchecked Never
oVirt gerrit 43206 master ABANDONED engine: Add KSM policy to NUMA hosts Never
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-09 20:20:52 EST

  None (edit)
Comment 3 Dudi Maroshi 2015-03-02 09:48:40 EST
Following conversation with rgolan@redhat.com
This is the planned actions solving this RFE.

1. Use NOTT11 host (Numa capable) to enable kernels 'boolean knob /sys/kernel/mm/ksm/merge_nodes'. Test its configuration at runtime.
1.2 Design programmatic solution to config  'boolean knob /sys/kernel/mm/ksm/merge_nodes' with vdsm deploy mechanism.
2. Append 'boolean knob /sys/kernel/mm/ksm/merge_nodes' boolean constant to Ovirt Engine config mechanism.
3. Program automatic configuration of  'boolean knob /sys/kernel/mm/ksm/merge_nodes' on vdsm deploy mechanism.
4. Test automatic configuration of  'boolean knob /sys/kernel/mm/ksm/merge_nodes' on vdsm deploy mechanism.
5. Program a unit test for  'boolean knob /sys/kernel/mm/ksm/merge_nodes'  effective install.

Please comment.
Comment 4 Roy Golan 2015-03-03 03:13:13 EST
- an /etc/modprobe.d/ovirt-ksm.conf should be
created if not already exist (maybe under different name) instead of altering /proc at runtime as the host-deploy is rebooting the host.

- special care for oVirt Node - by design oVirt Node config is stateless so need to make sure that is persisted - consult with Fabian Deutsch fdeutsch@redhat.com
Comment 7 Max Kovgan 2015-06-28 10:12:56 EDT
ovirt-3.6.0-3 release
Comment 8 Artyom 2015-09-06 08:01:36 EDT
Verified on rhevm-3.6.0-0.12.master.el6.noarch According to polarion plan https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=3%5F6%5FSLA%5FNuma%5FAware%5FKsm%5FSupport%5Frun
Comment 10 errata-xmlrpc 2016-03-09 15:27:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html

Note You need to log in before you can comment on or make changes to this bug.