Bug 840179 - Latest grub2 update broke "system" theme
Latest grub2 update broke "system" theme
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 902886 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-07-14 02:01 EDT by Kriton Kyrimis
Modified: 2013-01-28 04:26 EST (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 18:54:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (381 bytes, text/plain)
2012-07-14 02:01 EDT, Kriton Kyrimis
no flags Details

  None (edit)
Description Kriton Kyrimis 2012-07-14 02:01:15 EDT
Created attachment 598215 [details]
Proposed patch

Description of problem:
The name of the background image used by the theme in /boot/grub2/themes/system/theme.txt has changed to background.png, but /boot/grub2/themes/system/theme.txt still refers to this image as "fireworks.png". Thus, if the theme is activated, an error message appears instead of the fancy menu.

Version-Release number of selected component (if applicable):
grub2-tools-2.0-0.37.beta6.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Append the following line:
GRUB_THEME="/boot/grub2/themes/system/theme.txt"
to /etc/default/grub
2. Run
grub2-mkconfig -o /boot/grub2/grub.cfg
3. Reboot
  
Actual results:
When booting, an error message appears about /boot/grub2/themes/system/fireworks.png missing, prompting the user to hit enter. After hitting the enter key, a plain grub2 menu appears.

Expected results:
A fancy grub2 menu.

Additional info:
The theme used to work until the latest update to grub2. Applying the attached patch seems to fix the problem.
Comment 1 Eric Work 2012-07-17 03:24:56 EDT
I can confirm this problem.  I changed my theme to the starfield theme until this is resolved.
GRUB_THEME="/boot/grub2/themes/starfield/theme.txt"
Comment 2 Alexander Dalloz 2012-07-18 13:58:50 EDT
Here the latest grub2-tools package 0.37.beta6.fc17 broke the system theme with errors about missing both the fireworks.png background picture and the dejavu.pf2 font.
The package does not ship with a background.png file as the reporter seems to see.
Comment 3 Paul Howarth 2012-07-18 14:06:55 EDT
(In reply to comment #2)
> Here the latest grub2-tools package 0.37.beta6.fc17 broke the system theme
> with errors about missing both the fireworks.png background picture and the
> dejavu.pf2 font.
> The package does not ship with a background.png file as the reporter seems
> to see.

Agreed on all counts. The file /boot/grub2/themes/system/background.png comes from the fedora-logos package.
Comment 4 Vadim Rutkovsky 2012-08-16 08:13:41 EDT
Also reproduced on installed 18 Alpha TC2
Comment 5 Jaroslav Reznik 2012-08-16 09:35:56 EDT
Yep, it affects Alpha TC2 too using text installer which probably does not install fedora-logos (as it seems to be minimal text installation). As I can't log into the system, I can't confirm it.

Adding Jesse to CC confirm it.
Comment 6 Jesse Keating 2012-08-16 13:48:44 EDT
(In reply to comment #5)
> Yep, it affects Alpha TC2 too using text installer which probably does not
> install fedora-logos (as it seems to be minimal text installation). As I
> can't log into the system, I can't confirm it.
> 
> Adding Jesse to CC confirm it.

2 problems.

1) grub config on boot media
2) grub config /after/ install

1 has nothing to do with text/graphical mode.

2 can have something to do with text mode, since text mode currently only installs the minimal package set.  However anaconda can (and will soon) force the install of fedora-logos package, regardless of your package selection, which will fix problem 2 on text mode, once problem 1 gets fixed so that the config is pointing to the right file.
Comment 7 Tim Flink 2012-08-16 20:07:39 EDT
I just hit this after graphical install using a custom boot.iso (containing what will eventually be in F18 Alpha TC3).

The theme.txt is specifying a 'fireworks.png' image which doesn't exist. fedora-logos provides a 'background.png'.

When I change the theme.txt file to point to 'background.png', the theme shows up without issue.

I don't know if the bug is in grub2-tools or in fedora-logos but something is named wrong.

Proposing as a blocker for Fedora 18 alpha due to violation of the following Fedora 18 alpha release criterion [1] :

The default Fedora artwork must either refer to the current Fedora release under development (Fedora 18), or reference an interim release milestone (e.g. Alpha or Beta). If a release version number is used, it must match the current Fedora release under development. This includes artwork used in the installer, graphical bootloader menu, firstboot, graphical boot, graphical login and desktop background.

[1] http://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria
Comment 8 Adam Williamson 2012-08-17 15:21:44 EDT
I think we decided for F17 that that criterion didn't require artwork actually *show up*, but that if artwork did show up it must be correct.
Comment 9 Michael Cronenworth 2012-08-17 16:32:01 EDT
Please take bureaucracy out of this for a second.

This bug can be fixed with the one-liner patch that is already attached to this bug. It can be fixed in either grub2 or fedora-logos. Please... someone just take 10 seconds out of their busy schedules and apply the patch or change the name in fedora-logos.
Comment 10 Adam Williamson 2012-08-17 18:20:01 EDT
Michael: the blocker process 'bureaucracy' is really orthogonal to work on fixing the bug, but it has to happen, because F18 is frozen for Alpha. Even if someone applies the patch and does a build, it can't go into the f18 repo and hence the Alpha compose unless it is considered a blocker or NTH bug. If it isn't, then it will stay in updates-testing until Alpha is shipped.
Comment 11 Michael Cronenworth 2012-08-17 19:40:19 EDT
I'm not looking for this to be in F18 Alpha.

It's broken in F17+. It would take less than 10 seconds for someone with commit access to grub2/fedora-logos to fix this. It's been sitting here for over a month untouched. Can someone just push a fix for this? Worry about your QA labeling of this bug /after/ it has been fixed.
Comment 12 Adam Williamson 2012-08-18 00:04:39 EDT
Q: What's less productive than bureaucracy?

A: Bugzilla arguments.

When a bug gets proposed as a blocker it has to get reviewed. We have the blocker process for a reason. You denigrating it as 'bureaucracy' and me defending it is wasting your time and my time, and ironically, making me less likely to fix the bug because now it's pissing me off and I want to spend my time doing something else.

The blocker process is not bureaucracy. Insulting it is not a good way to convince anyone to fix a bug. Please leave it alone.
Comment 13 Michael Cronenworth 2012-08-18 12:25:40 EDT
I've put in for commit access. I'm putting my money where my mouth is. First person to grant me will see this bug fixed.
Comment 14 Nils Philippsen 2012-08-20 10:37:05 EDT
I think the release criterion mentioned in comment #7 as a reason for blocking on this bug isn't well chosen, others are violated much more clearly:

16. In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a working user account
[...]
18. When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should boot to a state where it is possible to log in through at least one of the default virtual consoles

IMO, grub2 not booting linux without someone hitting "Return" violates 16 and at least "scratches" 18 (depending on interpretation). Is this sufficient to get the formalities out of the way?
Comment 15 Mads Kiilerich 2012-08-20 11:02:25 EDT
(In reply to comment #13)
> I've put in for commit access. I'm putting my money where my mouth is. First
> person to grant me will see this bug fixed.

This is modern times. Better send a link to a git repo where it has been fixed.
Comment 16 Adam Williamson 2012-08-20 19:25:41 EDT
Discussed at 2012-08-20 QA meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-08-20/fedora-qa.2012-08-20-15.00.html . Accepted as a blocker per criterion "In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode."
Comment 17 Adam Williamson 2012-08-20 21:42:18 EDT
Tom, Peter, can you guys look into this one? The fix _seems_ obvious - change theme.txt (which is in theme.tar.bz2 in the grub2 build) to say background.png not fireworks.png . But the thing that worries me is that, AFAICT, the file was _never_ fireworks.png in any build of fedora-logos, it's always been background.png. So how did this ever work? Makes me worry I might be missing something, so I don't just want to poke this unilaterally. Thanks.
Comment 18 Tom "spot" Callaway 2012-08-21 08:03:23 EDT
My only thought here is that if we left it as "background.png", i think would be simpler to update the grub2 image at dist-upgrade time.

That said, I don't see any reason why we can't have fireworks.png as a symlink to background.png.
Comment 19 Fedora Update System 2012-08-21 08:35:15 EDT
fedora-logos-17.0.2-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedora-logos-17.0.2-5.fc17
Comment 20 Fedora Update System 2012-08-21 08:35:28 EDT
fedora-logos-17.0.2-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-logos-17.0.2-5.fc18
Comment 21 Mads Kiilerich 2012-08-21 09:02:55 EDT
The problem was introduced in grub2 between beta4 and beta6 in http://pkgs.fedoraproject.org/cgit/grub2.git/commit/?id=8c81c575874abe8193a2ef6c71b47b7efe6b2bdc where the theme for unknown changed from
  desktop-image: "background.png"
to
  desktop-image: "fireworks.png"

It would be better if the issue also was fixed in grub2.

(This whole 'system' theme in an unversioned tarball (but heavily based on the grub2 starfield theme) is a bit odd. If it is considered separate and fedora specific artwork it should be a separate or different package. If it is an improvement of the upstream project it should be upstreamed. If the upstream theme just need a bit of patching to make the fedora theming optional then it should be done in a separate patch. And in any case it shouldn't be installed in /boot/grub2/themes; that location is usually managed by grub2-install when installing from /usr/share/grub/themes/.)
Comment 22 Fedora Update System 2012-08-21 13:07:36 EDT
Package fedora-logos-17.0.2-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-logos-17.0.2-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12403/fedora-logos-17.0.2-5.fc18
then log in and leave karma (feedback).
Comment 23 Fedora Update System 2012-08-27 18:54:23 EDT
fedora-logos-17.0.2-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2012-08-27 21:31:29 EDT
fedora-logos-17.0.2-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Tuncay Göncüoğlu 2013-01-28 04:26:06 EST
*** Bug 902886 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.