Bug 840391 - wireless mouse works only through hub
wireless mouse works only through hub
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
hid logitec_dj first=3.2 tested=3.4.4-5
:
: 904875 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 04:51 EDT by kpijarski
Modified: 2013-03-21 20:16 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-10 21:22:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 958174 None None None 2012-07-16 10:08:58 EDT

  None (edit)
Description kpijarski 2012-07-16 04:51:13 EDT
Description of problem:

hello,

i just installed fedora 17 (64bit) on a new computer (a dell inspiron 7520), and am having the following issue: my wireless logitech mouse works with a hub, but it does not work *without* a hub anymore. all the ports on the laptop are usb 3.0, but the hub is usb 2.0.

dmesg when plugged directly into the computer:

[ 5106.901515] usb 3-4: new full-speed USB device number 14 using xhci_hcd
[ 5106.915115] usb 3-4: New USB device found, idVendor=046d, idProduct=c52b
[ 5106.915121] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5106.915124] usb 3-4: Product: USB Receiver
[ 5106.915126] usb 3-4: Manufacturer: Logitech
[ 5106.918268] logitech-djreceiver 0003:046D:C52B.0020: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-4/input2
[ 5106.918534] logitech-djreceiver 0003:046D:C52B.0020: logi_dj_probe:logi_dj_recv_query_paired_devices error:-32
[ 5106.918747] logitech-djreceiver: probe of 0003:046D:C52B.0020 failed with error -32

dmesg when plugged into the hub:

[ 5356.068340] usb 3-1.1: new full-speed USB device number 15 using xhci_hcd
[ 5356.082123] usb 3-1.1: New USB device found, idVendor=046d, idProduct=c52b
[ 5356.082128] usb 3-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5356.082142] usb 3-1.1: Product: USB Receiver
[ 5356.082144] usb 3-1.1: Manufacturer: Logitech
[ 5356.085787] logitech-djreceiver 0003:046D:C52B.0023: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-1.1/input2
[ 5356.088998] input: Logitech Unifying Device. Wireless PID:101d as /devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1.1/3-1.1:1.2/0003:046D:C52B.0023/input/input14
[ 5356.089199] logitech-djdevice 0003:046D:C52B.0024: input,hidraw1: USB HID v1.11 Mouse [Logitech Unifying Device. Wireless PID:101d] on usb-0000:00:14.0-1.1:1
[ 5356.091077] input: Logitech Unifying Device. Wireless PID:2007 as /devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1.1/3-1.1:1.2/0003:046D:C52B.0023/input/input15
[ 5356.091204] logitech-djdevice 0003:046D:C52B.0025: input,hidraw2: USB HID v1.11 Keyboard [Logitech Unifying Device. Wireless PID:2007] on usb-0000:00:14.0-1.1:2


i'd be grateful for any help, cheers!


Version-Release number of selected component (if applicable):

in the discussion on bug 823815 i was suggested that this might be a kernel bug (the other suggestion was that it is a hardware problem, but i don't think so, because the mouse/keyboard don't work on any of the usb 3.0 ports, but do work whenever i connect them through my usb 2.0 hub, both mouse/keyboard and hub work on my other computer)
i am on kernel 3.4.4-5.fc17.x86_64


How reproducible:
always

Steps to Reproduce:
1. plug logitech unfied receiver into usb 3.0 port
2.
3.
  
Actual results:
mouse doesn't work

Expected results:
mouse should work

Additional info:
plug the same receiver into the same port, but using a hub (usb 2.0) → everything works just fine
Comment 1 Michal Schmidt 2012-07-16 04:56:25 EDT
This report in Ubuntu looks like a similar problem:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/971854
Somebody there suggested a workaround:
 modprobe -r hid_logitech_dj
 modprobe -r usbhid
 modprobe usbhid

It would be useful to know if it helps.

Your problem may be resolved faster if you could test whether the bug happens also with a current upstream kernel from Linus's git tree and then posting about your problem to the upstream linux-input mailing list:
http://vger.kernel.org/vger-lists.html#linux-input
(or maybe to linux-usb).
Comment 2 kpijarski 2012-07-16 07:38:41 EDT
hello michal, 
thanks for you quick reply - yes, it does seem this is the same bug, but the workaround doesn't work, unfortunately.
unloading hid_logitech_dj work fine, but trying to remove usbhid results in the foolowing message:
libkmod: kmod_module_get_holders: could not open '/sys/module/usbhid/holders': No such file or directory
Error: Module usbhid is in use

as to the upstream kernel - i did compile my own kernel once or twice (on ubuntu), but i have no idea how to go about compiling a kernel from git. any reasonable how-tos out there?

Thanks!
Comment 3 kpijarski 2012-07-16 08:49:07 EDT
ok, i think this is the relevant launchpad bug fot this issue: https://bugs.launchpad.net/ubuntu/+bug/958174

there also is an appropriate kernel bug filed for this issue:
https://bugzilla.kernel.org/show_bug.cgi?id=43631

does this seem right?
Comment 4 Josh Boyer 2012-07-16 10:08:58 EDT
According to the launchpad bug, this is a regression introduced by commit 4ea5454203d991ec upstream.  Seems logitech is working on a fix.  We'll monitor.
Comment 5 Robert Hoffmann 2012-12-28 17:01:51 EST
Hello guys, 
I just installed FC17 on a brand new Vaio S (japanese version) and I found the following, which appears to be related to this.

1. I could not get the NetworkManager to work (it would actually semi-hang the box , unless I removed and blacklisted the "sierra" module)
2. After I got that working, I plugged in my Logitech wireless USB mouse, and it was working fine, until I did a yum upgrade.
current kernel: 3.6.10-2.fc17.i686.PAE #1 SMP Tue Dec 11 18:27:35 UTC 2012 i686 i686 i386 GNU/Linux

the error I got in /var/log/messages is:
Dec 28 22:36:38 yuko kernel: [ 1072.671312] logitech-djreceiver 0003:046D:C52B.0006: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-3/input2
Dec 28 22:36:38 yuko kernel: [ 1072.671592] logitech-djreceiver 0003:046D:C52B.0006: logi_dj_probe:logi_dj_recv_query_paired_devices error:-32
Dec 28 22:36:38 yuko kernel: [ 1072.672389] logitech-djreceiver: probe of 0003:046D:C52B.0006 failed with error -32



after doing:
   modprobe -r hid_logitech_dj
   modprobe -r usbhid
   modprobe usbhid

then replugging the mouse I still got zilch, no response,
Then I did a modprobe hid_logitech_dj


Now my mods looklike this:
[root@yuko ~]# lsmod | grep usb
btusb                  23199  0 
bluetooth             275642  24 bnep,btusb,rfcomm
[root@yuko ~]# lsmod | grep logi
hid_logitech_dj        18173  0 

Then I changed the little wireless usb dongle from one port to another, and voilla mouse is working as reported by the messages file:
Dec 28 22:36:47 yuko kernel: [ 1081.418364] usb 3-3: USB disconnect, device number 3
Dec 28 22:36:55 yuko kernel: [ 1089.402670] usb 3-1: new full-speed USB device number 4 using xhci_hcd
Dec 28 22:36:55 yuko kernel: [ 1089.416257] usb 3-1: New USB device found, idVendor=046d, idProduct=c52b
Dec 28 22:36:55 yuko kernel: [ 1089.416265] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Dec 28 22:36:55 yuko kernel: [ 1089.416269] usb 3-1: Product: USB Receiver
Dec 28 22:36:55 yuko kernel: [ 1089.416272] usb 3-1: Manufacturer: Logitech
Dec 28 22:36:55 yuko kernel: [ 1089.422906] logitech-djreceiver 0003:046D:C52B.0009: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-1/input2
Dec 28 22:36:55 yuko kernel: [ 1089.425089] input: Logitech Unifying Device. Wireless PID:400a as /devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.2/0003:046D:C52B.0009/input/input13
Dec 28 22:36:55 yuko kernel: [ 1089.425353] logitech-djdevice 0003:046D:C52B.000A: input,hidraw1: USB HID v1.11 Mouse [Logitech Unifying Device. Wireless PID:400a] on usb-0000:00:14.0-1:1
Dec 28 22:36:55 yuko mtp-probe: checking bus 3, device 4: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1"
Dec 28 22:36:55 yuko mtp-probe: bus: 3, device: 4 was not an MTP device



this is my lsusb:
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 08ff:168f AuthenTec, Inc. 
Bus 001 Device 004: ID 8087:07d6 Intel Corp. 
Bus 001 Device 005: ID 0489:d601 Foxconn / Hon Hai 
Bus 001 Device 006: ID 1199:68a2 Sierra Wireless, Inc. 
Bus 001 Device 007: ID 0489:e04d Foxconn / Hon Hai 


----------
p.s.: about the sierra mod, well the machine would not go past the login, i.e. no gnome, nothing , and I noticed the sierra messages on the black screen of forever-wait:
Dec 29 02:08:52 yuko kernel: [    9.587568] sierra: v.1.7.16:USB Driver for Sierra Wireless USB modems
Dec 29 02:08:56 yuko kernel: [   18.351839] sierra ttyUSB0: sierra_submit_rx_urbs: submit urb failed: -8
Dec 29 02:08:56 yuko kernel: [   18.352408] sierra ttyUSB0: sierra_submit_rx_urbs: submit urb failed: -8
Dec 29 02:08:56 yuko kernel: [   18.352954] sierra ttyUSB0: sierra_submit_rx_urbs: submit urb failed: -8
Dec 29 02:08:56 yuko kernel: [   18.353486] sierra ttyUSB0: sierra_submit_rx_urbs: submit urb failed: -8

so I went into recovery mode (fancy word for singleuser i guess lol) and blacklisted the sierra mod.

p.s.: only win8 the machine saw was the UEFI boot screens in japanese which i had to decode with my wife's help, until i got to the BIOS and was able to set up legacy boot mode and wipe the beast clean.
Comment 6 Robert Hoffmann 2012-12-28 23:56:27 EST
Update:

I was able to reproduce this problem in my other new Vaio Z.
And I also seem to have found a "fix".

If I unplug and replug the small dongle on the computer, while the mouse is "switched on" then the problem always happens (error -32)

But, if I turn off the mouse before plugging the dongle back in, and once plugged in, then everything works fine "as advertised".

I hope this kicks the ball into logitech/user court.

cheers
Comment 7 Benjamin Tissoires 2013-02-11 13:57:38 EST
The problem has been reported upstream only yesterday :(

Here is my answer and an attempt to fix the problem (which seems hardware related):
https://patchwork.kernel.org/patch/2125381/

To sum up, the USB3 interfere with the receiver, and the command is not correctly sent. The driver should not give up in such cases and try later to re-probe the mouse.

Cheers,
Benjamin
Comment 8 Benjamin Tissoires 2013-02-11 14:59:28 EST
*** Bug 904875 has been marked as a duplicate of this bug. ***
Comment 9 Benjamin Tissoires 2013-03-07 11:53:20 EST
The fix has been accepted upstream:
https://git.kernel.org/cgit/linux/kernel/git/jikos/hid.git/commit/?h=for-3.9/upstream-fixes&id=dcd9006b1b053c7b1cebe81333261d4fd492ffeb

It will be pushed into 3.9 and be sent to stable as soon as it lands into Linus' tree.
Comment 10 Josh Boyer 2013-03-07 13:12:22 EST
Patch applied to F17/F18.  Rawhide should pick it up naturally.  Thanks Benjamin.
Comment 11 Fedora Update System 2013-03-08 13:43:09 EST
kernel-3.8.2-206.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.8.2-206.fc18
Comment 12 Fedora Update System 2013-03-08 17:16:33 EST
kernel-3.8.2-105.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.8.2-105.fc17
Comment 13 Fedora Update System 2013-03-09 19:59:33 EST
Package kernel-3.8.2-206.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.8.2-206.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3630/kernel-3.8.2-206.fc18
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-03-10 21:22:04 EDT
kernel-3.8.2-206.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-03-14 11:20:04 EDT
kernel-3.8.2-105.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2013-3638/kernel-3.8.2-105.fc17
Comment 16 Fedora Update System 2013-03-14 18:56:08 EDT
kernel-3.8.3-101.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.8.3-101.fc17
Comment 17 Fedora Update System 2013-03-21 20:16:51 EDT
kernel-3.8.3-103.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.