Bug 904875 - Logitech Unifying Device can't work after F18(x86_64) reboot, until replug it more than once.
Logitech Unifying Device can't work after F18(x86_64) reboot, until replug it...
Status: CLOSED DUPLICATE of bug 840391
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-27 20:34 EST by ebird98
Modified: 2013-02-11 14:59 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-11 14:59:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ebird98 2013-01-27 20:34:09 EST
Description of problem:
Logitech mouse can't work,Logitech Unifying Device can't work after Fedora18 reboot, util replug it.

Version-Release number of selected component (if applicable):
kernel 3.7.4-204.fc18.x86_64
xorg-x11-drv-evdev.x86_64               2.7.3-2.fc18                   @anaconda
xorg-x11-drv-fbdev.x86_64               0.4.3-3.fc18                   @anaconda
xorg-x11-drv-intel.x86_64               2.20.17-1.fc18                 @updates 
xorg-x11-drv-mga.x86_64                 1.6.1-2.fc18                   @anaconda
xorg-x11-drv-modesetting.x86_64         0.6.0-1.fc18                   @updates 
xorg-x11-drv-nouveau.x86_64             1:1.0.6-1.fc18                 @updates 
xorg-x11-drv-openchrome.x86_64          0.3.1-1.fc18                   @anaconda
xorg-x11-drv-qxl.x86_64                 0.0.22-5.20120718gitde6620788.fc18
xorg-x11-drv-synaptics.x86_64           1.6.2-8.fc18                   @updates 
xorg-x11-drv-vmmouse.x86_64             13.0.0-1.fc18                  @updates 
libgudev1.x86_64                        197-1.fc18.1                   @updates 

Hardware info:
notebook computer: Lenovo zhaoyang K49.
Mouse: Logitech M505.

How reproducible:


Steps to Reproduce:
1.Boot Fedora 18 x86_64, install the , try to use the mouse.
2.reboot Fedora 18 x86_64, try to use the mouse.
  
Actual results:
1.When excute step 1, mouse work normally.
2.after step 2, mouse can't work.

Log in /var/log/message such this:

Jan 28 16:52:52 localhost kernel: [    3.162472] logitech-djreceiver 0003:046D:C52B.00
03: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00
:14.0-3/input2
Jan 28 16:52:52 localhost kernel: [    3.162763] logitech-djreceiver 0003:046D:C52B.00
03: logi_dj_probe:logi_dj_recv_query_paired_devices error:-32
Jan 28 16:52:52 localhost kernel: [    3.163891] logitech-djreceiver: probe of 0003:04
6D:C52B.0003 failed with error -32


Expected results:
Logitech Unifying Device should work normally after Fedora18 reboot.

Additional info:

When no errors occured, LOG such this:

 28 08:53:36 localhost kernel: [   68.086268] usb 3-3: new full-speed USB device number 3 using xhci_hcd
Jan 28 08:53:36 localhost kernel: [   68.100234] usb 3-3: New USB device found, idVendor=046d, idProduct=c52b
Jan 28 08:53:36 localhost kernel: [   68.100241] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jan 28 08:53:36 localhost kernel: [   68.100245] usb 3-3: Product: USB Receiver
Jan 28 08:53:36 localhost kernel: [   68.100248] usb 3-3: Manufacturer: Logitech
Jan 28 08:53:36 localhost kernel: [   68.106986] logitech-djreceiver 0003:046D:C52B.0006: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-3/input2
Jan 28 08:53:36 localhost kernel: [   68.108692] input: Logitech Unifying Device. Wireless PID:101d as /devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.2/0003:046D:C52B.0006/input/input12
Jan 28 08:53:36 localhost kernel: [   68.109239] logitech-djdevice 0003:046D:C52B.0007: input,hidraw1: USB HID v1.11 Mouse [Logitech Unifying Device. Wireless PID:101d] on usb-0000:00:14.0-3:1
Jan 28 08:53:36 localhost kernel: [   68.110682] input: Logitech Unifying Device. Wireless PID:101d as /devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.2/0003:046D:C52B.0006/input/input13
Jan 28 08:53:36 localhost kernel: [   68.111039] logitech-djdevice 0003:046D:C52B.0008: input,hidraw2: USB HID v1.11 Mouse [Logitech Unifying Device. Wireless PID:101d] on usb-0000:00:14.0-3:2
Jan 28 08:53:36 localhost mtp-probe: checking bus 3, device 3: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-3"
Comment 1 ebird98 2013-01-27 20:46:38 EST
Steps to Reproduce:
1.Boot Fedora 18 x86_64, install the Logitech Unifying Device, try to use the mouse.
2.reboot Fedora 18 x86_64, try to use the mouse.

==
sorry for missing a word.
Comment 2 Benjamin Tissoires 2013-02-11 14:59:28 EST
Same problem as 840391, it's a USB3 issue.

*** This bug has been marked as a duplicate of bug 840391 ***

Note You need to log in before you can comment on or make changes to this bug.