Bug 840438 - Backend: rhevm doesn't move host to non-operational due to missing required network on cluster 3.0
Backend: rhevm doesn't move host to non-operational due to missing required n...
Status: CLOSED DUPLICATE of bug 822451
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: lpeer
meital avital
network
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 07:45 EDT by Avi Tal
Modified: 2016-04-22 01:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 09:26:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log (330.56 KB, application/x-compressed-tar)
2012-07-16 07:45 EDT, Avi Tal
no flags Details

  None (edit)
Description Avi Tal 2012-07-16 07:45:33 EDT
Created attachment 598431 [details]
engine log

Description of problem:
rhevm 3.1 with cluster 3.0: host doesn't move to non-operational due to missing required network.
This can cause some critical issues with VM connectivity and migration

Steps to Reproduce:
1. create required network "sw2"
2. attach to host eth2
3. move eth2 down (unplug or ifdown: as long as operstat=down)
  
Actual results:
host will stay up

Expected results:
host should move to non-operational after 60 sec

* vdsm does show that eth2 status is down:
# vdsClient 0 getVdsStats
'eth2': {'macAddr': '', 'name': 'eth2', 'txDropped': '0', 'rxErrors': '0', 'txRate': '0.0', 'rxRate': '0.0', 'txErrors': '0', 'state': 'down', ...

# brctl show
bridge name     bridge id               STP enabled     interfaces
rhevm           8000.001517a76a4c       no              eth0
sw1             8000.001d0968714e       no              eth2

[root@silver-vdsa ~]# virsh -r net-list
Name                 State      Autostart
-----------------------------------------
vdsm-rhevm           active     yes       
vdsm-sw1             active     yes
Comment 1 Avi Tal 2012-07-16 09:26:46 EDT

*** This bug has been marked as a duplicate of bug 822451 ***

Note You need to log in before you can comment on or make changes to this bug.