Bug 840818 - Implement a server side quorum in glusterd
Implement a server side quorum in glusterd
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.0
Assigned To: Pranith Kumar K
Sachidananda Urs
: Reopened
Depends On: 839595 840122 874018
Blocks: 858428 865324
  Show dependency treegraph
 
Reported: 2012-07-17 05:45 EDT by Scott Haines
Modified: 2015-05-13 11:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa4-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 840122
: 858428 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:29:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Sachidananda Urs 2013-01-08 04:23:59 EST
Quorum behaves as expected. Enabled quorum on 4 machines

# gluster volume set foo cluster.server-quorum-type server

Set the percentage to 75% and bring down a couple of servers, quorum is not met and the glusterfsds are killed on other systems.
Comment 2 Scott Haines 2013-09-23 18:29:52 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.