Bug 840988 - RFE: Ability to define custom installation repo in recipeset without need to inject custom kickstart
RFE: Ability to define custom installation repo in recipeset without need to ...
Status: CLOSED DUPLICATE of bug 633369
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Bill Peck
Misc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 15:39 EDT by Gabriel Szasz
Modified: 2014-08-12 00:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 22:14:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Szasz 2012-07-17 15:39:42 EDT
Motivation: We need to install RHEL 6.2 directly from the repo containing recent RHEL 6.2.Z build [1] instead of standard RHEL 6.2 [2]. Otherwise "yum update" takes too long and it significantly prolongs the test time that is needed for the scheduled job. Currently the only bullet-proof way how to reach the desired behavior is to provide custom kickstart with modified "repo" command via <kickstart> tag (providing custom distribution repo URL). As far as the only altered part of the provided kickstart file are the "repo" commands, this solution is adding undesired complexity into our recipesets (and also into the code that is generating the recipeset in our Jenkins job).


Proposal: We propose to improve functionality of the existing <repo> tag, to allow user to specify that the custom repo will not be just added to the /etc/yum.repos.d in the %post section, but it will be also add corresponding "repo" command and thus Anaconda will use custom repo during installation.

For our tests is also essential to add the possibility to replace (or override) the "repo" command that defines distribution repo URL, as far as we want Beaker to use the provided distribution repo URL (e.g. [1]) instead of [2].


Note: To be correct, the default kickstart for RHEL 6.2 is actually specifying [3] in the repo command (to allow Anaconda to access RHEL 6.2 repo via NFS). Nevertheless, using [1] instead of [3] reduces our test-time anyway (as described in the motivation section above).


[1] http://download.lab.bos.redhat.com/brewroot/repos/RHEL-6.2-Z-build/latest/x86_64
[2] http://download.eng.bos.redhat.com/released/RHEL-6/6.2/Server/x86_64/os/Server
[3] nfs:bigpapi.bos.redhat.com:/vol/engarchive2/redhat/released/RHEL-6/6.2/Server/x86_64/os/
Comment 1 Dan Callaghan 2012-09-27 22:14:31 EDT

*** This bug has been marked as a duplicate of bug 633369 ***

Note You need to log in before you can comment on or make changes to this bug.