Bug 84123 - XFree86 nv driver will not display digital interface of dell 1503
XFree86 nv driver will not display digital interface of dell 1503
Status: CLOSED DUPLICATE of bug 88360
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-12 10:28 EST by Harris Landgarten
Modified: 2007-04-18 12:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harris Landgarten 2003-02-12 10:28:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
The nv driver when configured for the digital interface on the dell 1503 LCD
monitor causes the monitor to display "cannot display video". This was a problem
with the nv driver in rh8 as well. The native NVIDIA driver displayed properly
on the digital interface but this driver will not rebuild on phoebe.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.redhat-config-xfree86
2.probe finds nvidia
3. select dell1503 digital as monitor
4. reboot with monitor connected via DVI
    

Actual Results:  Text mode displays properly but when X starts the monitor
refuses to display as it is being overdriven.

Expected Results:  graphical display

Additional info:

NVIDIA GeForce 2 GTS (generic)

when I change vertical refresh to 60-60. I get an unstable vertical roll on the
display but atleast something is displayed.

The same behavior occurs when attempting graphical installation with anancoda if
connected via the DVI input. Text mode intallation works properly.
Comment 1 Brent Fox 2003-02-12 11:41:59 EST
Can you run 'ddcprobe' as root and paste the output to this report?  

We should be able to probe the 1503FP.  I have a 1702FP at home that can be
probed just fine.  Perhaps the entries in the MonitorsDB is wrong.
Comment 2 Brent Fox 2003-02-12 14:14:10 EST
Ah, Mike Harris tells me that using DVI with NVidia hardware is currently
unsupported.  Try running ddcprobe while using the VGA connector instead of the
DVI.  Does that work?
Comment 3 Harris Landgarten 2003-02-12 14:31:41 EST
Videocard DDC probe results
while in analog mode in gnome

Description:  NVidia Corporation NV15 Reference Board
Memory (MB):  64
 
Monitor DDC probe results
ID: DEL3004
Name: Dell 1503FP (Analog)
Horizontal Sync (kHZ): 30-60
Vertical Sync (HZ)  : 60-75
Width (mm): 300
Height(mm): 220

while in digital mode init 3

Videocard DDC probe results
Description:      NVidia Corporation NV15 Reference Board
Memory  (MB)  64

Monitor DDC probe results
Monitor DDC Probe failed
Comment 4 Brent Fox 2003-02-12 14:40:16 EST
Ok, it looks like our database entries are more-or-less correct.

The monitor returns 30-60 and 60-75.  MonitorsDB says:

Dell; Dell 1503FP (Analog); del3004; 31.0-60.0; 60.0-75.0; 1
Dell; Dell 1503FP (Digital); del3003; 31.0-60.0; 60.0-75.0; 1

It looks like I should change the "31" to "30".  But that's not the real problem.


Does running redhat-config-xfree86 with the analog connector work?  It looks
like probing the monitor should be correct as long as you aren't using DVI.
Comment 5 Harris Landgarten 2003-02-12 15:01:21 EST
The monitor runs X fine in analog but I changed Vert to 60-60 because 60hz is
optimal.
Comment 6 Brent Fox 2003-02-12 16:59:26 EST
Ok, I'm glad to know that things work ok in analog mode.

I'm going to transfer this bug to XFree86 since the bug is actually in the
nvidia driver.  mharris is probably going to close as 'wontfix' since I think
that this bug is due to the lack of hardware specifications from nVidia for
their cards.
Comment 7 Mike A. Harris 2003-02-17 15:45:46 EST
Please report this issue in the "nv" driver upstream to the XFree86
mailing list and bug report address:  xfree86@xfree86.org

The "nv" driver maintainer, whom works at Nvidia, reads that list and will
be able to assess the problem for you, and make official comments on what
the driver does and does not support.  He will also be potentially able to
fix the issue, or to add support if it is missing, since only Nvidia
employees have access to the Nvidia hardware specifications and in depth
knowledge of the Nvidia hardware.

Hopefully a future release of the "nv" driver will support this, or
work correctly for DVI displays.

Changing bug status to UPSTREAM.
Comment 8 Mike A. Harris 2003-07-17 06:20:30 EDT
I'm processing UPSTREAM flagged bug reports for upstream fixes currently, and
noticed that this bug was flagged upstream but has no upstream bug URL, and I
was unable to find an upstream bug report of this issue in XFree86 bugzilla
located at:

    http://bugs.xfree86.org

Closing bug report as WONTFIX as I'm unable to track upstream until a bug
report has been filed upstream, and the URL provided for tracking.  If this
issue is still relevant in the latest XFree86 packages in rawhide, after
reporting upstream at http://bugs.xfree86.org, feel free to add the bug
report URL to this report and reopen if you'd like the issue to be tracked
and any fixes from upstream investigated for inclusion in future Red Hat
XFree86 updates.

Comment 9 Mike A. Harris 2003-09-26 20:58:09 EDT

*** This bug has been marked as a duplicate of 88360 ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:51:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.