Bug 88360 - (nvidiadvi) NV driver does not work with DFP displays very well
NV driver does not work with DFP displays very well
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://bugs.xfree86.org//cgi-bin/bugz...
: MoveUpstream
: 80581 84123 84656 84775 84834 89472 98110 105756 108469 109263 109487 110416 111173 111408 112112 112983 115506 115636 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-09 09:02 EDT by Thomas J. Baker
Modified: 2007-04-18 12:52 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 12:20:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2003-04-09 09:02:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I have a Dell Precision 650N (3.0GHz P4 x 2) with an NVidia Quadro4 900 XGL card
and a Dell 2000FP Flat Panel monitor. Using the digital connections, the nv
driver doesn't work (screen flashed pink blinking squares). If I use the analog
input to the 2000FP, it works fine.

Here's an lspci on the card:

01:00.0 VGA compatible controller: nVidia Corporation NV25GL [Quadro4 900 XGL]
(rev a3) (prog-if 00 [VGA])
        Subsystem: nVidia Corporation: Unknown device 0138
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 16
        Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Memory at eff80000 (32-bit, prefetchable) [size=512K]
        Expansion ROM at c1000000 [disabled] [size=128K]
        Capabilities: <available only to root>


Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Try to start X using the DVI out of the card connected to the DVI in of the
monitor.
2.
3.
    

Actual Results:  Pink flashing blocks.

Expected Results:  X should work.

Additional info:

I can provide any more info you need. The only reason I learned of the work
around is because NVidia's drivers lockup problems with SMP and DVI.
Comment 1 Mike A. Harris 2003-04-09 12:03:20 EDT
Please report this problem directly to XFree86.org so that the "nv" driver
maintainer whom is an Nvidia employee can investigate this matter.  Red Hat
does not have the technical specifications for Nvidia video hardware as
they do not make them available, so it is not possible for us to implement
features in the "nv" driver, nor fix most bugs in the driver either.

You can report this problem at: http://bugs.xfree86.org

If you find a solution, or patch, please attach it to this bug report
and we can investigate adding it to a future build.

Thanks.
Comment 2 Thomas J. Baker 2003-04-11 08:35:59 EDT
Here's what I got from XFree and adding both options worked for me.

------- Additional Comments From Mark Vojkovich 2003-04-10 17:15 -------

4.3 works, it just doesn't autodetect which head it's on very well.  You may
need to explicitly tell the driver to use the second output with:

 Option "CrtcNumber" "1"

That's usually enough, but it might possibly also need Option "FlatPanel".
From what I've seen if the DVI connector is hooked up to the second output you
just need the CrtcNumber hint.
Comment 3 Thomas J. Baker 2003-04-11 08:36:56 EDT
For completeness, here's the XFree bugzilla bug:

http://bugs.xfree86.org//cgi-bin/bugzilla/show_bug.cgi?id=133   
Comment 4 Mike A. Harris 2003-07-17 06:53:01 EDT
*** Bug 98110 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2003-07-17 06:56:43 EDT
It seems many people are reporting the "nv" driver doesn't work well with
DVI panels, so I'm making this report the master bug tracker to close duplicates
against for the future.

Hopefully Nvidia will spend time working on improving DVI support in the "nv"
driver for XFree86 4.4.0.  If so, we can investigate the possibility of back
porting the driver to 4.3.0 for future erratum.
Comment 6 Mike A. Harris 2003-09-26 20:57:21 EDT
*** Bug 80581 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2003-09-26 20:58:12 EDT
*** Bug 84123 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2003-09-26 20:59:21 EDT
*** Bug 84656 has been marked as a duplicate of this bug. ***
Comment 9 Mike A. Harris 2003-09-26 21:00:16 EDT
*** Bug 84775 has been marked as a duplicate of this bug. ***
Comment 10 Mike A. Harris 2003-09-26 21:00:29 EDT
*** Bug 84834 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2003-09-26 21:02:10 EDT
*** Bug 89472 has been marked as a duplicate of this bug. ***
Comment 12 Mike A. Harris 2003-09-26 21:02:37 EDT
*** Bug 105756 has been marked as a duplicate of this bug. ***
Comment 13 Mike A. Harris 2003-11-09 04:42:19 EST
*** Bug 108469 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2003-11-10 16:20:53 EST
*** Bug 109487 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Katz 2003-11-21 16:08:18 EST
*** Bug 110416 has been marked as a duplicate of this bug. ***
Comment 16 Faisal Malallah 2003-11-21 20:54:00 EST
I downloaded Nividia's 4496 build driver and installed it on Fedora
Core 1. The digital connection via DVI worked pretty well. 
Comment 17 Jeremy Katz 2003-11-28 18:05:26 EST
*** Bug 111173 has been marked as a duplicate of this bug. ***
Comment 18 Mike A. Harris 2003-11-28 20:10:38 EST
Allegedly, XFree86 4.4.0 once released, will support Nvidia DVI
much more completely.  I've investigated the code briefly to see if
I could do a wholesale "nv" driver update, but the driver has undergone
major rewriting and reformatting, so it isn't easy to isolate changes.

Once 4.4.0 is released however, and integrated into the distribution,
users should hopefully see better DFP support.  I'll update this
bug report once I've got packages in rawhide, if I remember.  ;o)
Comment 19 Jeremy Katz 2003-12-03 14:31:17 EST
*** Bug 111408 has been marked as a duplicate of this bug. ***
Comment 20 Mike A. Harris 2004-01-06 18:11:18 EST
*** Bug 112983 has been marked as a duplicate of this bug. ***
Comment 21 Mike A. Harris 2004-02-13 01:33:47 EST
*** Bug 115506 has been marked as a duplicate of this bug. ***
Comment 22 Jeremy Katz 2004-02-14 14:47:26 EST
*** Bug 115636 has been marked as a duplicate of this bug. ***
Comment 23 Mike A. Harris 2004-02-17 11:06:44 EST
*** Bug 109263 has been marked as a duplicate of this bug. ***
Comment 24 Mike A. Harris 2004-03-05 18:41:54 EST
*** Bug 112112 has been marked as a duplicate of this bug. ***
Comment 25 Mike A. Harris 2004-06-24 12:20:06 EDT
The 'nv' driver present in X.Org X11R6.7.0 in Fedora Core 2 contains
support for DFP display types.

Changing status to resolved in 'CURRENTRELEASE'.

Note You need to log in before you can comment on or make changes to this bug.