Bug 841396 - Select First Subscription in My Subscriptions table by Default
Select First Subscription in My Subscriptions table by Default
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: John Sefler
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-18 17:09 EDT by Matt Reid
Modified: 2013-01-07 22:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:57:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first of "My Subscriptions" is selected by default (54.50 KB, image/png)
2012-09-07 19:00 EDT, John Sefler
no flags Details
another view of the default selected "My Subscription" that is currently expired (45.49 KB, image/png)
2012-09-07 19:02 EDT, John Sefler
no flags Details

  None (edit)
Description Matt Reid 2012-07-18 17:09:24 EDT
Description of problem:
After seeing some confusion from users in the My Installed Products tab over not knowing products in the table were selectable, we made it so that the first Product in the table was selected by default. BZ 811340

I didn't want to carry that over to My Subscriptions initially, since the selection highlight would replace the row coloring we used to show (with no way to deselect it if there was only one entry). Now that we're changing how we call out expiring/expired subscriptions to not rely on a row highlight, and instead use an icon and a highlight in the details, we could safely select the first subscription here as well so that the details pane is populated when they first switch to the tab.
Comment 1 Alex Wood 2012-08-22 10:37:49 EDT
commit 134c000b2fc4f88cad36f82a93d9a42c72004c71
Refs: <origin/awood/841396>, awood/841396, subscription-manager-1.0.14-1-11-g13~
Author:     Alex Wood <awood@redhat.com>
AuthorDate: Tue Aug 21 16:43:17 2012 -0400
Commit:     Alex Wood <awood@redhat.com>
CommitDate: Tue Aug 21 16:44:13 2012 -0400

    841396: Select first item in My Subscriptions table by default.
Comment 2 RHEL Product and Program Management 2012-08-22 10:38:14 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 John Sefler 2012-09-07 19:00:00 EDT
Created attachment 610854 [details]
first of "My Subscriptions" is selected by default

Verifying version...
[root@rhsm-accept-rhel5 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.0.17-1.el5

After registering and autosubscribing or manually subscribing and then clicking to the "My Subscriptions" tab, the first of the consumed subscriptions is now automatically selected by default thereby populating the Subscription Details pane for the default selected subscription.

Moving to VERIFIED.
Comment 5 John Sefler 2012-09-07 19:02:49 EDT
Created attachment 610857 [details]
another view of the default selected "My Subscription" that is currently expired

attaching another screenshot to show an example of the highlighted details and icon on an expired subscription that mreid referred to in comment 0
Comment 7 errata-xmlrpc 2013-01-07 22:57:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.