This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 841428 - Document mod_jk connectors
Document mod_jk connectors
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-HTTP-Connectors-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Misha H. Ali
:
: 865720 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 20:40 EDT by Misha H. Ali
Modified: 2012-11-08 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:10:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2012-07-18 20:40:20 EDT
Add documentation about mod_jk connectors. The planned outline looks like this:

1. Configuring the Web Subsystem
1.1. Basic Configuration
1.2. Configuring Connectors
1.2.1. Configuring HTTP Connectors
1.2.2. Configuring HTTPS Connectors
1.2.3. Configuring AJP Connectors
1.2.4. Configuring Native Connectors
1.3. Configuring Virtual Servers
1.4. Querying Connectors
Comment 1 Misha H. Ali 2012-07-18 20:41:03 EDT
A first draft is developed and feedback attained from SME.
Comment 3 Libor Fuka 2012-10-10 08:46:41 EDT
looks different in the doc right now
Comment 4 Jan Stefl 2012-10-12 05:03:12 EDT
*** Bug 865720 has been marked as a duplicate of this bug. ***
Comment 5 Jan Stefl 2012-10-12 05:03:37 EDT
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/HTTP_Connectors_Load_Balancing_Guide/clustering-http-jboss.html

{original}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(
               socket-binding=custom, scheme=http, protocol="HTTP/1.1", enabled=true
               ))
{original}

{should-be}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(socket-binding=custom,scheme=http,protocol="HTTP/1.1",enabled=true)
{should-be}

----------------------------------------------------------------------------

Configure the HTTP Connector
{original}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(
               socket-binding=custom, scheme=http, protocol="HTTP/1.1", enabled=true
               )
{original}

this is command for creating new connector - it is wrong.

-----------------------------------------------------------------------------

Use the Socket Binding to Create a New HTTPS Connector
{original}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(socket-binding=https, scheme=https, protocol="HTTP/1.1", enabled=true, ssl = {})
{original}

paramater ssl is not supported (at least in EAP 6.0.1.ER2 does not work)

I think, it was ment:
{maybe}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(socket-binding=https, scheme=https, protocol="HTTP/1.1", enabled=true, secure = true)
{maybe}

------------------------------------------------------------------------------

I belive that somewhere in this chapter should be link to EAP doc, where mod_jk configuration is explained to details. Smth. like:

https://access.redhat.com/knowledge/docs/en-US/JBoss_Enterprise_Application_Platform/6/html-single/Administration_and_Configuration_Guide/index.html#sect-Apache_mod_jk
Comment 6 Misha H. Ali 2012-10-12 06:14:29 EDT
(In reply to comment #5)
> http://documentation-devel.engineering.redhat.com/docs/en-US/
> JBoss_Enterprise_Web_Server/2/html/HTTP_Connectors_Load_Balancing_Guide/
> clustering-http-jboss.html
> 
> {original}
> [standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(
>                socket-binding=custom, scheme=http, protocol="HTTP/1.1",
> enabled=true
>                ))
> {original}
> 
> {should-be}
> [standalone@localhost:9999 /]
> /subsystem=web/connector=test-connector:add(socket-binding=custom,
> scheme=http,protocol="HTTP/1.1",enabled=true)
> {should-be}
> 
> ----------------------------------------------------------------------------
> 

Fixed.

> Configure the HTTP Connector
> {original}
> [standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(
>                socket-binding=custom, scheme=http, protocol="HTTP/1.1",
> enabled=true
>                )
> {original}
> 
> this is command for creating new connector - it is wrong.
> 
> -----------------------------------------------------------------------------
> 

Adding Jean-Frederic to figure out the correct command the above.

> Use the Socket Binding to Create a New HTTPS Connector
> {original}
> [standalone@localhost:9999 /]
> /subsystem=web/connector=test-connector:add(socket-binding=https,
> scheme=https, protocol="HTTP/1.1", enabled=true, ssl = {})
> {original}
> 
> paramater ssl is not supported (at least in EAP 6.0.1.ER2 does not work)
> 
> I think, it was ment:
> {maybe}
> [standalone@localhost:9999 /]
> /subsystem=web/connector=test-connector:add(socket-binding=https,
> scheme=https, protocol="HTTP/1.1", enabled=true, secure = true)
> {maybe}
> 
> -----------------------------------------------------------------------------
> -

Fixed above.

> 
> I belive that somewhere in this chapter should be link to EAP doc, where
> mod_jk configuration is explained to details. Smth. like:
> 
> https://access.redhat.com/knowledge/docs/en-US/
> JBoss_Enterprise_Application_Platform/6/html-single/
> Administration_and_Configuration_Guide/index.html#sect-Apache_mod_jk

Added a new section after this one to clearly state where further details are found.
Comment 7 Jean-frederic Clere 2012-10-12 09:34:04 EDT
For the ssl: I am afraid that is a bug in AS7 :-(
Comment 8 Misha H. Ali 2012-10-13 02:12:56 EDT
> > Configure the HTTP Connector
> > {original}
> > [standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(
> >                socket-binding=custom, scheme=http, protocol="HTTP/1.1",
> > enabled=true
> >                )
> > {original}
> > 
> > this is command for creating new connector - it is wrong.
> > 

Jean-Frederic, would you mind adding info about the correct way to configure the HTTP connector?

> > Use the Socket Binding to Create a New HTTPS Connector
> > {original}
> > [standalone@localhost:9999 /]
> > /subsystem=web/connector=test-connector:add(socket-binding=https,
> > scheme=https, protocol="HTTP/1.1", enabled=true, ssl = {})
> > {original}
> > 
> > paramater ssl is not supported (at least in EAP 6.0.1.ER2 does not work)
> > 
> > I think, it was ment:
> > {maybe}
> > [standalone@localhost:9999 /]
> > /subsystem=web/connector=test-connector:add(socket-binding=https,
> > scheme=https, protocol="HTTP/1.1", enabled=true, secure = true)
> > {maybe}
> > 
> > ----------------------------------------------------------------------------

I used your correction, Radhim. What is the recommended approach to this now? Can we leave out SSL and still do this successfully? Sorry Jean-Frederic, I must tag you here again, as I have no idea how to work around this issue.
Comment 9 Jean-frederic Clere 2012-10-15 02:48:43 EDT
Actually the ssl configuration needs to be added after adding the connector.
/subsystem=web/connector=test-connector:add(socket-binding=https,scheme=https, protocol="HTTP/1.1", enabled=true, secure = true)
/subsystem=web/connector=test-connector/configuration=ssl:add
:reload

Note that the node must be restarted _immediately_, because the connector runs without ssl when the first add is done.
Comment 11 Jan Stefl 2012-10-22 11:04:30 EDT
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/HTTP_Connectors_Load_Balancing_Guide/clustering-http-jboss.html

There are problems in procedures
 - Procedure 3.4. Configure HTTP Connectors
  - there is code for for HTTPS connector (see 2. Configure the HTTP Connector), please use the code mentioned here in comment 5 (item 1)
  - move item "3. Use a Socket Binding to Create a New HTTP Connector" into procedure Procedure "3.5. Configure HTTPS Connectors", just behind "2. Use the Socket Binding to Create a New HTTPS Connector" and rename it to smth. like "Reload SSL configuration" and add text "Note that the node must be restarted _immediately_, because the connector runs without ssl when the first add is done."
Comment 12 Jean-frederic Clere 2012-10-22 11:08:33 EDT
the command :reload does it, just some more explanations would be nice.
Comment 13 Misha H. Ali 2012-10-22 20:02:11 EDT
(In reply to comment #11)
> http://documentation-devel.engineering.redhat.com/docs/en-US/
> JBoss_Enterprise_Web_Server/2/html/HTTP_Connectors_Load_Balancing_Guide/
> clustering-http-jboss.html
> 
> There are problems in procedures
>  - Procedure 3.4. Configure HTTP Connectors
>   - there is code for for HTTPS connector (see 2. Configure the HTTP
> Connector), please use the code mentioned here in comment 5 (item 1)

Code updated.

>   - move item "3. Use a Socket Binding to Create a New HTTP Connector" into
> procedure Procedure "3.5. Configure HTTPS Connectors", just behind "2. Use
> the Socket Binding to Create a New HTTPS Connector" and rename it to smth.
> like "Reload SSL configuration" and add text "Note that the node must be
> restarted _immediately_, because the connector runs without ssl when the
> first add is done."

Moved to Procedure 3.5 as the new Step 2, renamed and adjusted text. Also added an important note as directed.
Comment 15 Jan Stefl 2012-10-23 02:50:14 EDT
It is needed to swap parts 
Reload the SSL Configuration <-> Use the Socket Binding to Create a New HTTPS Connector
in "Procedure 3.5. Configure HTTPS Connectors"
Comment 16 Misha H. Ali 2012-10-23 03:25:00 EDT
Jan, just to clarify, do you mean that the title of the switched out step should remain Use the Socket Binding etc. rather than the new title Reload the SSL Configuration? If I have misunderstood you, please let me know.
Comment 17 Jan Stefl 2012-10-23 03:39:34 EDT
Misha, 

"Procedure 3.5. Configure HTTPS Connectors"
1. Create a New Socket Binding (this is OK) ...

2. Use the Socket Binding to Create a New HTTPS Connector
Use the following configuration to create a new HTTPS connector with an unused socket binding: ...

3. Reload the SSL Configuration
Use the following configuration to reload the SSL configuration for a HTTP connector: ...
Comment 18 Misha H. Ali 2012-10-23 19:13:33 EDT
Thanks for the clarification, Jan. This bug will be set to ON_QA once this change appears on the stage.
Comment 20 Jean-frederic Clere 2012-10-24 04:05:37 EDT
In fact I don't like the stuff I suggested...
3 Reload the SSL Configuration: (Reload looks weird).


In fact the good sequence to create an ssl connector should be the following:

/subsystem=web/connector=test-connector:add(socket-binding=https, scheme=https, protocol="HTTP/1.1", enabled=false, secure = true)
/subsystem=web/connector=test-connector/configuration=ssl:add
/subsystem=web/connector=test-connector:write-attribute(name=enabled, value=true)
:reload
Comment 21 Jean-frederic Clere 2012-10-24 04:15:50 EDT
1 - Create a New Socket Binding
 - UNCHANGED -

2 - Use the Socket Binding to Create a New HTTPS Connector
  - just change enabled=true into enabled=true

3 - Add the SSL configuration to the connector
  /subsystem=web/connector=test-connector/configuration=ssl:add
  Note: That use the default configuration for SSL (for JSSE: the keystore in ${user.home}/.keystore and the password "changeit", for OpenSSL: there isn't a default configuration so you need to configure the configuration=ssl element correctly).

See http://docs.jboss.org/jbossweb/7.0.x/config/ssl.html
Comment 22 Jean-frederic Clere 2012-10-24 04:17:33 EDT
4 - Reload the server to get the new configuration active:
  :reload

And remove the Important note....
Comment 23 Misha H. Ali 2012-10-25 00:14:18 EDT
Updated Procedure 3.5.

(In reply to comment #21)
> 1 - Create a New Socket Binding
>  - UNCHANGED -
> 
> 2 - Use the Socket Binding to Create a New HTTPS Connector
>   - just change enabled=true into enabled=true
> 

Changed to enabled=false. I assume this was intended based on Jean-Frederic's comment#20.

> 3 - Add the SSL configuration to the connector
>   /subsystem=web/connector=test-connector/configuration=ssl:add
>   Note: That use the default configuration for SSL (for JSSE: the keystore
> in ${user.home}/.keystore and the password "changeit", for OpenSSL: there
> isn't a default configuration so you need to configure the configuration=ssl
> element correctly).

Updated with note.

Also:

(In reply to comment #22)

> 4 - Reload the server to get the new configuration active:
>  :reload

Added step 4.

> And remove the Important note....

Removed note.
Comment 25 Jan Stefl 2012-10-25 02:12:11 EDT
Great!
just please add link from comment 21 into related note:

See http://docs.jboss.org/jbossweb/7.0.x/config/ssl.html
Comment 26 Jean-frederic Clere 2012-10-25 02:37:42 EDT
crap I missed the command to enable the connector before the :reload

/subsystem=web/connector=test-connector:write-attribute(name=enabled, value=true)

So I think we need:

4 - enable the connnector:
/subsystem=web/connector=test-connector:write-attribute(name=enabled, value=true)

5 -  Reload the server to get the new configuration active:
:reload
Comment 27 Jean-frederic Clere 2012-10-25 02:38:26 EDT
4 - enable the connnector:
s/connnector/connector
Comment 28 Misha H. Ali 2012-10-25 03:41:04 EDT
No problem. This bug will be set to ON_QA when this change appears on the stage.
Comment 29 Misha H. Ali 2012-10-25 06:26:07 EDT
Sorry folks, the doc stage is down again or at least not refreshing for over 3 hours. Please verify the updates here instead for now:

http://file.bne.redhat.com/~mhusnain/HTTP_Connectors_Guide/html-single/#idp41381488
Comment 30 Jan Stefl 2012-10-25 07:08:15 EDT
Looks OK now.
Congrats!
Comment 31 Misha H. Ali 2012-11-08 17:10:24 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.