Bug 865720 - [HTTP Connectors Load Balancing Guide]: 3.2. Configuring JBoss Enterprise Application Platform to Work with mod_jk
[HTTP Connectors Load Balancing Guide]: 3.2. Configuring JBoss Enterprise App...
Status: CLOSED DUPLICATE of bug 841428
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-HTTP-Connectors-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 05:00 EDT by Jan Stefl
Modified: 2012-10-12 05:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 05:03:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stefl 2012-10-12 05:00:55 EDT
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/HTTP_Connectors_Load_Balancing_Guide/clustering-http-jboss.html

{original}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(
               socket-binding=custom, scheme=http, protocol="HTTP/1.1", enabled=true
               ))
{original}

{should-be}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(socket-binding=custom,scheme=http,protocol="HTTP/1.1",enabled=true)
{should-be}

----------------------------------------------------------------------------

Configure the HTTP Connector
{original}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(
               socket-binding=custom, scheme=http, protocol="HTTP/1.1", enabled=true
               )
{original}

this is command for creating new connector - it is wrong.

-----------------------------------------------------------------------------

Use the Socket Binding to Create a New HTTPS Connector
{original}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(socket-binding=https, scheme=https, protocol="HTTP/1.1", enabled=true, ssl = {})
{original}

paramater ssl is not supported (at least in EAP 6.0.1.ER2 does not work)

I think, it was ment:
{maybe}
[standalone@localhost:9999 /] /subsystem=web/connector=test-connector:add(socket-binding=https, scheme=https, protocol="HTTP/1.1", enabled=true, secure = true)
{maybe}

------------------------------------------------------------------------------

I belive that somewhere in this chapter should be link to EAP doc, where mod_jk configuration is explained to details. Smth. like:

https://access.redhat.com/knowledge/docs/en-US/JBoss_Enterprise_Application_Platform/6/html-single/Administration_and_Configuration_Guide/index.html#sect-Apache_mod_jk
Comment 1 Jan Stefl 2012-10-12 05:03:12 EDT

*** This bug has been marked as a duplicate of bug 841428 ***

Note You need to log in before you can comment on or make changes to this bug.