Bug 841854 - bluetooth dialog crashes when pressing on/off button in device tab
bluetooth dialog crashes when pressing on/off button in device tab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.1
x86_64 Linux
medium Severity medium
: beta
: 7.0
Assigned To: Bastien Nocera
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 07:59 EDT by Vladimir Benes
Modified: 2014-06-13 09:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:18:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hopefully correct backtrace :-) (10.58 KB, text/plain)
2012-07-20 08:02 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2012-07-20 07:59:45 EDT
Description of problem:
when I try to disconnect device via c-c bluetooth I get this segfault.. 

Version-Release number of selected component (if applicable):
control-center-3.4.2-2.el7.x86_64

How reproducible:
95% :-)

Steps to Reproduce:
1.connect bluetooth device 
2.go into c-c bluetooth dialog 
3.press on/off
4.repeate several times
  
Actual results:
crash

Expected results:
no crash

Additional info:
Comment 1 Vladimir Benes 2012-07-20 08:02:51 EDT
Created attachment 599377 [details]
hopefully correct backtrace :-)
Comment 2 Ray Strode [halfline] 2012-09-19 11:43:20 EDT
I don't think this backtrace is correct. this seems to be a crash in the languages chooser which is in the region panel not the bluetooth panel.
Comment 3 Bastien Nocera 2012-10-15 11:53:41 EDT
This seems to be a backtrace for bug 838636. Do you have one for that Bluetooth crash?
Comment 4 Bastien Nocera 2012-11-09 05:59:13 EST
Bug was fixed upstream, will be in gnome-bluetooth 3.6.1.

commit 2f13ee50bfac745979a01e6c826dd3c4d3f741cd
Author: Bastien Nocera <hadess@hadess.net>
Date:   Tue Oct 30 12:12:37 2012 +0100

    lib: Fix refcounting problems with Connect/Disconnect
    
    Proxies related to particular interfaces were unref'ed even
    though we never took a new reference to them, and the incorrect
    GDBusProxy was used in some cases, causing crashers.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=686172
Comment 5 Vladimir Benes 2013-01-15 08:56:55 EST
control-center-3.6.3-1.el7.x86_64 no crashes any more
-> VERIFIED
Comment 6 Ludek Smid 2014-06-13 09:18:34 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.