Bug 842113 - No pop up error message when configuring more NICs than allowed on VM
No pop up error message when configuring more NICs than allowed on VM
Status: CLOSED DUPLICATE of bug 842112
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: lpeer
Depends On:
  Show dependency treegraph
Reported: 2012-07-22 04:26 EDT by GenadiC
Modified: 2012-07-30 07:20 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-07-30 07:20:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
engine log with the problem attached (2.81 MB, application/octet-stream)
2012-07-24 03:54 EDT, GenadiC
no flags Details

  None (edit)
Description GenadiC 2012-07-22 04:26:18 EDT
Description of problem:
If you configure more NICs on the VM than allowed you are supposed to get a pop up error message and you do not.

How reproducible:

Steps to Reproduce:
1. Create max amount of NICs on VM 
2. Try to add additional NIC
Actual results:
No pop up error message is displayed in GUI, although the action fails

Expected results:
Pop up message should be displayed with appropriate error

Additional info:
I created 24 NICs on VM to reproduce the problem and got the following on engine log: CanDoAction of action AddVmInterface failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__INTERFACE,NETWORK_INTERFACE_NAME_ALREADY_IN_USE
Comment 1 lpeer 2012-07-22 06:43:38 EDT
Can you please attach backend logs?
Comment 2 GenadiC 2012-07-24 03:54:29 EDT
Created attachment 599935 [details]
engine log with the problem attached
Comment 3 Alona Kaplan 2012-07-24 04:53:18 EDT
works for me.
Comment 4 GenadiC 2012-07-26 05:59:15 EDT
It happens randomly (at least 3 times in the last 2 days), will check if SI12 solved the problem
Comment 5 GenadiC 2012-07-29 05:46:34 EDT
We see the same behaviour in SI12 as well, so the problem is not solved
Comment 6 Alona Kaplan 2012-07-30 07:20:36 EDT

*** This bug has been marked as a duplicate of bug 842112 ***

Note You need to log in before you can comment on or make changes to this bug.