Bug 842112 - After restarting the jboss (and not refreshing the ff) queries to the backend fail
After restarting the jboss (and not refreshing the ff) queries to the backend...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Gilad Chaplik
GenadiC
ux
:
: 842113 842993 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 04:11 EDT by GenadiC
Modified: 2015-09-22 09 EDT (History)
10 users (show)

See Also:
Fixed In Version: si14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gwt error log (2.35 KB, text/x-log)
2012-07-30 04:33 EDT, Alona Kaplan
no flags Details

  None (edit)
Description GenadiC 2012-07-22 04:11:56 EDT
Description of problem:
If you configure the NIC on the VM with the same name as another NIC you don't get any pop up with error message


How reproducible:
Always

Steps to Reproduce:
1. Create a VM with at least one NIC
2. Add another NIC with the same name as the first one
  
Actual results:
No pop up message that the action fails appears in GUI

Expected results:

We should get pop up with error message, explaining the reason for failure

Additional info:
In engine log you could see the following:
CanDoAction of action AddVmInterface failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__INTERFACE,NETWORK_INTERFACE_NAME_ALREADY_IN_USE
Comment 1 Alona Kaplan 2012-07-24 04:52:28 EDT
Works for me.
Comment 2 GenadiC 2012-07-26 05:58:13 EDT
It happens randomly (at least 3 times in the last 2 days), will check if SI12 solved the problem
Comment 3 GenadiC 2012-07-29 05:48:39 EDT
We see the same behaviour in SI12 as well, so the problem is not solved
Comment 4 Alona Kaplan 2012-07-30 04:33:50 EDT
Created attachment 601144 [details]
gwt error log
Comment 5 Alona Kaplan 2012-07-30 04:40:24 EDT
As Meni found- the problem reproduces after restarting the Jboss (without restarting the ff).
It seems to be an infrastructure problem and not a network problem.
Comment 6 Alona Kaplan 2012-07-30 07:19:46 EDT
*** Bug 842993 has been marked as a duplicate of this bug. ***
Comment 7 Alona Kaplan 2012-07-30 07:20:36 EDT
*** Bug 842113 has been marked as a duplicate of this bug. ***
Comment 8 Gilad Chaplik 2012-08-05 11:07:50 EDT
pushed upstream (http://gerrit.ovirt.org/6912)
Comment 12 GenadiC 2012-08-16 06:51:44 EDT
Verified in SI14

Note You need to log in before you can comment on or make changes to this bug.