Bug 842315 - [RFE] No visibility of geo-replication from slave/target cluster(s)
[RFE] No visibility of geo-replication from slave/target cluster(s)
Status: CLOSED DUPLICATE of bug 1443923
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Aravinda VK
storage-qa-internal@redhat.com
: FutureFeature, Reopened, ZStream
: 850515 (view as bug list)
Depends On:
Blocks: 850514
  Show dependency treegraph
 
Reported: 2012-07-23 09:00 EDT by Paul Cuzner
Modified: 2017-09-06 02:05 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-06 02:05:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Cuzner 2012-07-23 09:00:34 EDT
Description of problem:
When a geo-replication relationship is established, it is only visible from the source cluster. This is an operational risk, and has been picked up not only through internal SA testing but also on customer POC engagements.

Not understanding the volume relationships across clusters can lead to data loss and human error - both of which woul dbe bad for RHS!

Version-Release number of selected component (if applicable):
2.0

How reproducible:
Whenever geo-replication is used.

Steps to Reproduce:
1. Create a geo-replication configuration
2. Login to the target/slave
3. Using the CLI attempt to show the replication status
  
Actual results:
Replication state is not shared between source and target clusters

Expected results:
Slave's should show the replication state either through vol info, or vol ge-replication commands or preferably both

Additional info:
Comment 2 Amar Tumballi 2013-05-15 06:02:25 EDT
Csaba, lets plan to fix this by just showing the 'stime' value on slave as the 'sync' status.
Comment 4 Vivek Agarwal 2013-09-25 03:31:52 EDT
*** Bug 850515 has been marked as a duplicate of this bug. ***
Comment 9 Aravinda VK 2017-09-06 02:05:53 EDT

*** This bug has been marked as a duplicate of bug 1443923 ***

Note You need to log in before you can comment on or make changes to this bug.