Bug 842784 - [pa][bn_IN] Failed pofilter untranslated tests are failing - CANDLEPIN
[pa][bn_IN] Failed pofilter untranslated tests are failing - CANDLEPIN
Status: CLOSED DUPLICATE of bug 1020474
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bryan Kearney
Katello QA List
: i18n, Translation
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-07-24 11:29 EDT by Sharath Dwaral
Modified: 2015-05-14 10:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-03 15:39:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-07-24 11:29:11 EDT
Description of problem:
For all languages, some msgids dont have appropriate msgstrs 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

$ ssh -XYC root@fsharath-candlepin.usersys.redhat.com
reverse mapping checking getaddrinfo for unused [10.16.120.164] failed - POSSIBLE BREAK-IN ATTEMPT!
root@fsharath-candlepin.usersys.redhat.com's password: 
Last login: Mon Jul 23 17:36:08 2012 from dhcp-230-63.rdu.redhat.com

# pofilter --gnome -t untranslated /root/candlepin/po/[LOCALE].po
  
Sample output:

# pofilter --gnome -t untranslated /root/candlepin/po/ja.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-06-27 12:35-0400\n"
"PO-Revision-Date: 2012-06-06 11:01-0400\n"
"Last-Translator: noriko <noriko@fedoraproject.org>\n"
"Language-Team: Japanese\n"
"Language: ja\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=1; plural=0\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) untranslated: checks whether a string has been translated at all
#: src/main/java/org/candlepin/resource/ActivationKeyResource.java:222
#, java-format
msgid "ActivationKey with id {0} could not be found."
msgstr ""

# (pofilter) untranslated: checks whether a string has been translated at all
#: src/main/java/org/candlepin/resource/ActivationKeyResource.java:233
#, java-format
msgid "Pool with id {0} could not be found."
msgstr ""

# (pofilter) untranslated: checks whether a string has been translated at all
#: src/main/java/org/candlepin/resource/SubscriptionResource.java:182
#, java-format
msgid "Subscription with id {0} could not be found."
msgstr ""

# (pofilter) untranslated: checks whether a string has been translated at all
#: src/main/java/org/candlepin/resource/ProductResource.java:110
#: src/main/java/org/candlepin/resource/ProductResource.java:129
#: src/main/java/org/candlepin/resource/ProductResource.java:189
#, java-format
msgid "Product with UUID ''{0}'' could not be found."
msgstr ""

# (pofilter) untranslated: checks whether a string has been translated at all
#: src/main/java/org/candlepin/resource/OwnerResource.java:253
#, java-format
msgid "Could not create the Owner: {0}. Parent {1} does not exist."
msgstr ""

............ Ignoring other Results ................

Additional info:

List of languages for which it fails :

fr, gu,or, bn_IN, te, pa, kn, de_DE, ja_JP, ru, zh_TW
hi, mr, zh_CN, as, pt_BR, it, ko, ml, ta_IN, es_ES
Comment 1 Bryan Kearney 2012-10-17 16:02:45 EDT
We have 99% in zanata right now. I am going to move this to ON_QA and we can look again in RHEL6.4 cycle.
Comment 2 John Sefler 2012-10-18 17:34:24 EDT
[root@jsefler-f14-candlepin candlepin]# git show-ref | grep master
42378c4866bd1c389d09b82b0251bcb6eaa6b5e5 refs/heads/master


[root@jsefler-f14-candlepin ~]#  pofilter --gnome -t untranslated /root/candlepin/po/ja.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-06-27 12:35-0400\n"
"PO-Revision-Date: 2012-09-23 07:13-0400\n"
"Last-Translator: nnakakit <nnakakit@fedoraproject.org>\n"
"Language-Team: Japanese\n"
"Language: ja\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=1; plural=0\n"
"X-Generator: Zanata 1.7.3\n"

# (pofilter) untranslated: Checks whether a string has been translated at all.
#: src/main/java/org/candlepin/resource/OwnerResource.java:766
#: src/main/java/org/candlepin/resource/ConsumerResource.java:466
#, java-format
msgid "Service level '{0}' is not available to consumers of organization {1}."
msgstr ""
[###########################################] 100%


Currenty that ^ is the 1% of untranslated msgids.
Moving back to NEW.
Please move back to MODIFIED after Zanata Candlepin master is 100% and translations have been pulled into master.
Comment 3 Adrian Likins 2013-03-25 17:34:38 EDT
commit 008c5cb336b141f300d647d6c71750b2cd15e066
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Mar 25 15:03:16 2013 -0400

    921126: latest string updates from zanata
    
    921126,911779,911776,911772,911764,911762,911759,
    911757,908886,908879,908869,908866,908521,908511,
    908488,908434,908108,908059,908037,906967,906552,
    842784
Comment 4 John Sefler 2013-03-29 11:00:36 EDT
Testing Version...
[root@jsefler-f14-candlepin po]# git show-ref | grep master
b3aba7272d1b310b5a7ddc20b0d7d99caf3295b0 refs/heads/master
https://translate.zanata.org/zanata/iteration/view/candlepin/master

The pofilter untranslated test continues to fail for LANGS:
pa.po
bn_IN.po

Moving back to ASSIGNED/FailedQA
Comment 5 Bryan Kearney 2014-02-03 15:39:46 EST

*** This bug has been marked as a duplicate of bug 1020474 ***

Note You need to log in before you can comment on or make changes to this bug.