Bug 1020474 - Zanata translations for subscription-manager 1.10 are not yet 100%
Zanata translations for subscription-manager 1.10 are not yet 100%
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Translation
: 842784 1030378 1071022 1074568 (view as bug list)
Depends On:
Blocks: rhsm-rhel70 1060074
  Show dependency treegraph
 
Reported: 2013-10-17 14:06 EDT by John Sefler
Modified: 2014-06-17 20:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:04:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-10-17 14:06:58 EDT
Description of problem:
Using this bugzilla to block automated VerifyTranslationFileContainsAllMsgids_Test.  Once all of the translations for subscription-manager 1.10 are 100% translated and merged into subscription-manager 1.10, move this bug to MODIFIED

https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.10.X


Once all tranlations are 100% and have been pulled into subscription-manager, the following query will report the same number of msgid translations for all langs:

# for i in `rpm -ql subscription-manager | grep rhsm.mo`; do echo $i; msgunfmt $i | grep msgid | wc -l; done;
Comment 1 Lijun Li 2014-01-20 05:03:56 EST
l10naudittool result with latest snapshot 3 build
http://10.66.33.87/L10nAudit/RHEL-7.0-20140116.1/data/subscription-manager-1.10.10-1.el7.log :

msgfmt --statistics ja.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics ko.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics zh_CN.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics zh_TW.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics pt_BR.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics fr.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics de_DE.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics zh_CN.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics ru.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics es_ES.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics as.po
829 translated messages.
msgfmt --statistics bn_IN.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics gu.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics hi.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics kn.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics ml.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics mr.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics or.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics pa.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics zh_CN.po
811 translated messages, 18 untranslated messages.
msgfmt --statistics te.po
811 translated messages, 18 untranslated messages.
Comment 2 Bryan Kearney 2014-02-03 15:39:46 EST
*** Bug 842784 has been marked as a duplicate of this bug. ***
Comment 4 Carter Kozak 2014-03-04 10:22:41 EST
*** Bug 1071022 has been marked as a duplicate of this bug. ***
Comment 5 Carter Kozak 2014-03-04 10:22:46 EST
*** Bug 1030378 has been marked as a duplicate of this bug. ***
Comment 7 John Sefler 2014-03-04 17:41:40 EST
As a result of rejected translations, Zanata no longer reports 100% translations.
https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.10.X
Comment 8 Carter Kozak 2014-03-19 12:45:05 EDT
*** Bug 1074568 has been marked as a duplicate of this bug. ***
Comment 9 John Sefler 2014-03-20 13:59:43 EDT
Today Zanata https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.10.X is 100% translated and has been built into package...

[root@jsefler-7 ~]# rpm -q subscription-manager
subscription-manager-1.10.14-5.el7.x86_64

[root@jsefler-7 ~]# for i in `rpm -ql subscription-manager | grep rhsm.mo`; do echo $i; msgunfmt $i | grep msgid | wc -l; done;
/usr/share/locale/as/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/bn_IN/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/fr/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/gu/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/hi/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/it/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/ja/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/kn/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/ko/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/ml/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/mr/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/or/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/pa/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/ru/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/ta_IN/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/te/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo
925
/usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo
925
[root@jsefler-7 ~]# 

VERIFIED: All langs have provided 925 translated strings.


Bug 1078483 is a known exception to this verification.
Comment 10 Ludek Smid 2014-06-13 09:04:27 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.