Bug 842786 - Please update to 0.12.5 to be rid of PyXML dependency
Please update to 0.12.5 to be rid of PyXML dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: SOAPpy (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843176
  Show dependency treegraph
 
Reported: 2012-07-24 11:31 EDT by Toshio Ernie Kuratomi
Modified: 2013-01-11 14:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 14:42:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2012-07-24 11:31:59 EDT
Description of problem:

SOAPpy currently has a dependency on PyXML.  We are trying to get rid of PyXML in the F18 because of two factors combined:

1) The upstream is long dead
2) The python stdlib imports pyxml and overwrites its own xml module with the pyxml one if the pyml one is installed.

The combination of these two means that older, buggy code is sometimes overwriting code from the stdlib.

For SOAPpy, we want to get rid of the dep on PyXML.  There's two possibilities here.

1) PyXML may be a false dep and we may be able to just remove it.  The ChangeLog for SOAPpy 0.10.3 says that PyXML was removed as a dep.  But the README still lists it.  Code review seems to look clean for the version of PyXML we have in Fedora.  We could remove the Requires: PyXML in the SOAPpy spec file if we think the README is a documentation bug.

2) We can update to the new version of SOAPpy.  It looks like upstream has "recently" been revived ( http://pypi.python.org/pypi/SOAPpy/ and https://github.com/kiorky/SOAPpy ).  The new versions of SOAPpy do not require pyxml and make no mention of it in the README.
Comment 1 Pierre-YvesChibon 2012-07-26 02:22:46 EDT
The latest release on rawhide does not Requires PyXML anymore.
Comment 2 Toshio Ernie Kuratomi 2013-01-11 14:42:52 EST
Retargetted removing PyXML as a F19 Feature so closing this fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.