Bug 842843 - Remove PyXML dep, add lxml
Remove PyXML dep, add lxml
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Young
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843176
  Show dependency treegraph
 
Reported: 2012-07-24 13:40 EDT by Toshio Ernie Kuratomi
Modified: 2012-08-05 18:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: xen-4.1.2-24.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-05 18:50:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove pyxml prettyprint use (662 bytes, patch)
2012-07-24 13:40 EDT, Toshio Ernie Kuratomi
no flags Details | Diff

  None (edit)
Description Toshio Ernie Kuratomi 2012-07-24 13:40:50 EDT
Created attachment 600143 [details]
Remove pyxml prettyprint use

Description of problem:

We're looking into getting rid of PyXML in Fedora 18 as it's dead upstream, suffers unfixed bugs, and has the dubious behaviour of overwriting the python stdlib's  xml module with its own code: https://bugzilla.redhat.com/show_bug.cgi?id=795875

Reviewing xen's use of PyXML, I have the following recommendations:

* It looks like upstream xen actively ported away from PyXML to lxml.  If that's complete the fedora package just has old deps that need to be updated:

- Requires: PyXML
+ Requires: python-lxml 

Adding Requires: python-lxml needs to be done whether or not the PyXML Requires can be removed right away.

Reviewing the code, I also found one place that's still using a PyXML module.  xm create with certain options can attempt to use PyXML to PrettyPrint its output.  I'll attach a patch to trivially fix this to use stdlib functionality instead.

Version-Release number of selected component (if applicable):
xen-4.1.2-2
Comment 1 Fedora Update System 2012-07-26 18:56:44 EDT
xen-4.1.2-24.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xen-4.1.2-24.fc17
Comment 2 Fedora Update System 2012-07-27 05:53:32 EDT
Package xen-4.1.2-24.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xen-4.1.2-24.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11182/xen-4.1.2-24.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-08-05 17:26:08 EDT
xen-4.1.2-24.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.