Bug 842853 - Replace PyXML dep with lxml dep
Replace PyXML dep with lxml dep
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: inksmoto (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843176
  Show dependency treegraph
 
Reported: 2012-07-24 14:09 EDT by Toshio Ernie Kuratomi
Modified: 2012-07-25 15:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 14:24:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2012-07-24 14:09:28 EDT
Description of problem:
We're looking into retiring PyXML in Fedora 18 due to dead upstream and PyXML replacing the stdlib's xml module with its own code if it's installed.  https://fedoraproject.org/wiki/User:Toshio/Remove_PyXML

I've looked at inksmoto's requirement on PyXML and I think we can get rid of it.  from the upstream mailing lists, it looks like they ported from pyxml to lxml at some point.  The code I grepped through appears to use lxml rather than PyXML.  So we should just be able to do

-Requires: PyXML
+Requires: python-lxml
Comment 1 Gwyn Ciesla 2012-07-24 14:24:20 EDT
Done.

Note You need to log in before you can comment on or make changes to this bug.