Bug 842887 - remove PyXML dep
remove PyXML dep
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: synce-sync-engine (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843176
  Show dependency treegraph
 
Reported: 2012-07-24 16:22 EDT by Toshio Ernie Kuratomi
Modified: 2012-07-26 15:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 15:12:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2012-07-24 16:22:45 EDT
Description of problem:
We're trying to remove PyXML from Fedora 18 because it is dead upstream and has the dubious behaviour of replacing the stdlib's xml module with its own code when it is installed.

I reviewed the xml code in synce-sync-engine and it looks like the package was ported from PyXML to libxml2-python at some point in the past.  So we should be able to just drop the Requires: PyXML from the package.

Note You need to log in before you can comment on or make changes to this bug.