Bug 842993 - No error when trying to remove network from Data Center when the network is attached to cluster
No error when trying to remove network from Data Center when the network is a...
Status: CLOSED DUPLICATE of bug 842112
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Einav Cohen
Meni Yakove
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 04:57 EDT by Meni Yakove
Modified: 2016-02-10 14:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 07:19:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meni Yakove 2012-07-25 04:57:11 EDT
Description of problem:
Network 'net1' is attached to cluster.
When trying to remove network 'net1' from Data Center tab the remove failed as it should but there is no popup with error, There is only error on engine.log:

2012-07-25 11:36:58,114 WARN  [org.ovirt.engine.core.bll.storage.RemoveNetworkCommand] (ajp-/0.0.0.0:8009-11) CanDoAction of action RemoveNetwork failed. Reasons:VAR__ACTION__REMOVE,VAR__TYPE__NETWORK,NETWORK_CLUSTER_NETWORK_IN_USE


Version-Release number of selected component (if applicable):
rhevm-3.1.0-7.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.Create network 'net1' and attach it to cluster
2.Go to Data Center > Logical Networks and try to remove the network 'net1'
3.
  
Actual results:
Remove of network 'net1' failed as is should but no error message.

Expected results:
Remove of network 'net1' failed with proper message.
Comment 1 Alona Kaplan 2012-07-30 07:19:46 EDT

*** This bug has been marked as a duplicate of bug 842112 ***

Note You need to log in before you can comment on or make changes to this bug.