Bug 843062 - F17 lorax update generates uninstallable anaconda media
F17 lorax update generates uninstallable anaconda media
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 846918 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 09:26 EDT by Jos Vos
Modified: 2012-10-11 13:47 EDT (History)
5 users (show)

See Also:
Fixed In Version: lorax-17.27-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 13:47:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2012-07-25 09:26:46 EDT
Description of problem:
Running pungi on an updated F17 system with lorax-17.26-1.fc17.x86_64 generates an install DVD where anaconda won't recognize any image type and runs into a Python exception at the second screen.

Version-Release number of selected component (if applicable):
17.26-1.fc17.x86_64

This patch seems to solve this problem:

http://git.fedorahosted.org/cgit/lorax.git/commit/?id=3636fd58146768b07f8814d4aeab395876d93a82

Please fix the F17 lorax, as pungi can't be used anymore without this manual fix now.
Comment 1 Jesse Keating 2012-08-09 13:55:59 EDT
*** Bug 846918 has been marked as a duplicate of this bug. ***
Comment 2 John Reiser 2012-08-09 14:41:48 EDT
Eventually this bug (and duplicates) also will hit the problem that you must exclude systemd-44-8.fc17 and systemd-sysv-44-8.fc17 because of a bug in that version.  Supposedly systemd-186 and above for Fedora 18 contain the fix, but there has been no backport (about 4 weeks so far).  After that, some people run into grub2-install not present because the .ks file omitted "@anaconda-tools".  See the thread "F17 updates broke anaconda PNG image handling" beginning July 24 in devel@lists.fedoraproject.org.

[Yes, some of this is redundant, but it may help those who wish to make progress while various pieces are not yet working.]
Comment 3 Fedora Update System 2012-09-13 20:34:36 EDT
lorax-17.27-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lorax-17.27-1.fc17
Comment 4 Fedora Update System 2012-09-17 13:51:41 EDT
Package lorax-17.27-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-17.27-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14146/lorax-17.27-1.fc17
then log in and leave karma (feedback).
Comment 5 upgradeservices 2012-10-02 16:33:13 EDT
update resolves the issue

Note You need to log in before you can comment on or make changes to this bug.