Bug 846918 - GError: Couldn't recognize the image file format for file '/usr/share/system-config-keyboard/pixmaps/system-config-keyboard.png'
Summary: GError: Couldn't recognize the image file format for file '/usr/share/system-...
Status: CLOSED DUPLICATE of bug 843062
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 17
Hardware: x86_64 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3ef87ab1c5768497926157fff00...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-09 06:25 UTC by Azamat H. Hackimov
Modified: 2013-01-10 06:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 17:55:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-y3N46x (77.13 KB, text/plain)
2012-08-09 06:25 UTC, Azamat H. Hackimov
no flags Details

Description Azamat H. Hackimov 2012-08-09 06:25:18 UTC
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-y3N46x
hashmarkername: anaconda
kernel:         3.5.0-2.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Thu 09 Aug 2012 06:23:44 AM UTC
version:        17

anaconda-tb-y3N46x: Text file, 78983 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/firstboot/functions.py", line 5, in loadPixbuf
:    return gtk.gdk.pixbuf_new_from_file(fn)
:  File "/usr/lib/python2.7/site-packages/firstboot/functions.py", line 8, in loadToImage
:    pix = loadPixbuf(fn)
:  File "/usr/share/system-config-keyboard/keyboard_gui.py", line 134, in createScreen
:    iconBox.pack_start(loadToImage(iconFile))
:  File "/usr/share/system-config-keyboard/keyboard_gui.py", line 225, in getScreen
:    self.createScreen(defaultByLang, kbd)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/kbd_gui.py", line 42, in getScreen
:    vbox = installKeyboardWindow.getScreen(self, default, anaconda.keyboard)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1270, in display_step
:    new_screen = self.currentWindow.getScreen(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1157, in display_step
:    return self.icw.display_step(step)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 387, in dispatch
:    rc = self.anaconda.intf.display_step(self.step)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:GError: Couldn't recognize the image file format for file '/usr/share/system-config-keyboard/pixmaps/system-config-keyboard.png'

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:PYTHONPATH=/tmp/updates
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.oNyhrh
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1

Comment 1 Azamat H. Hackimov 2012-08-09 06:25:21 UTC
Created attachment 603179 [details]
File: anaconda-tb-y3N46x

Comment 2 Azamat H. Hackimov 2012-08-09 06:28:53 UTC
Hello, I'm trying create custom Install DVD with manual https://fedoraproject.org/wiki/How_to_create_a_Fedora_install_ISO_for_testing
Create DVD produces this error.

Comment 3 Jesse Keating 2012-08-09 17:46:42 UTC
I believe this is caused by a broken package in updates or updates-testing.  When you are doing the compose are you enabling the updates (or updates-testing) repos?  If so, please disable those and see if the problem persists.

Comment 4 Jesse Keating 2012-08-09 17:55:59 UTC

*** This bug has been marked as a duplicate of bug 843062 ***


Note You need to log in before you can comment on or make changes to this bug.