Bug 843117 - Empty provider list if 'mock' not included in aeolus-configure
Empty provider list if 'mock' not included in aeolus-configure
Status: CLOSED NEXTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: John Eckersberg
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 12:05 EDT by Aaron Weitekamp
Modified: 2012-09-07 16:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 16:03:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
aeolus-configure.log (15.07 KB, text/x-log)
2012-07-25 12:05 EDT, Aaron Weitekamp
no flags Details

  None (edit)
Description Aaron Weitekamp 2012-07-25 12:05:35 EDT
Created attachment 600340 [details]
aeolus-configure.log

Description of problem:
Provider list is empty if 'mock' provider not included in aeolus-configure. User may add providers but it's very difficult to find the correct values for "EC2 name" and "Region".

Version-1.0.1 (from puddle):
# rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.34-1.el6cf.noarch
aeolus-all-0.8.34-1.el6cf.noarch
aeolus-conductor-0.8.34-1.el6cf.noarch
aeolus-configure-2.5.10-1.el6cf.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.8.34-1.el6cf.noarch


How reproducible: 100%


Steps to Reproduce:
# aeolus-configure -p ec2,admin

Actual results:
# aeolus-image list --providers
Name     Type     Target Reference     
----     ----     ----------------     

#


Expected results:
7 EC2 providers should be listed
* ec2-us-east-1, etc.
* ec2-us-west-1
* etc.

Additional info:
If 'mock' value included, as in 'aeolus-configure -p ec2,mock' all the EC2 providers are listed.

Error at ln 64 in log: 
Wed Jul 25 11:24:27 -0400 2012 /Stage[main]/Aeolus::Deltacloud::Core/Exec[deltacloud-core-startup-wait]/returns (err): change from notrun to 0 failed: /usr/bin/nc -z localhost 3002 returned 1 instead of one of [0] at /usr/share/aeolus-configure/modules/aeolus/manifests/deltacloud.pp:43
Comment 2 John Eckersberg 2012-09-07 16:03:52 EDT
Looks like this got fixed during the 1.1 development cycle.  Testing against the current 1.1 candidate on a fresh host:

# aeolus-configure -p ec2  # 'admin' profile is implied in 1.1
Launching aeolus configuration recipe...
-snip-
notice: Finished catalog run in 344.40 seconds

# aeolus-image list --providers
Name                   Type     Target Reference     
------------------     ----     ----------------     
ec2-ap-northeast-1     ec2      ap-northeast-1       
ec2-ap-southeast-1     ec2      ap-southeast-1       
ec2-eu-west-1          ec2      eu-west-1            
ec2-sa-east-1          ec2      sa-east-1            
ec2-us-east-1          ec2      us-east-1            
ec2-us-west-1          ec2      us-west-1            
ec2-us-west-2          ec2      us-west-2

Note You need to log in before you can comment on or make changes to this bug.