Bug 843807 - What number gives a higher priority?
What number gives a higher priority?
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: Documentation (Show other bugs)
1.1.0
x86_64 Linux
unspecified Severity medium
: beta6
: ---
Assigned To: Dan Macpherson
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 08:05 EDT by Forrest Taylor
Modified: 2012-12-10 16:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 16:48:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Forrest Taylor 2012-07-27 08:05:52 EDT
Description of problem:
When creating a Cloud Resource Provider, there is an opportunity to include a priority.  However there is no documentation regarding what the values mean.  If I assign a value of 1 to one provider and a value of 10 to another, which one is the higher priority?  Is it the higher number or the first number?

Also, there is no mention where this comes into play.  Is this value referenced when I choose auto-select in the Cluster when I launch?

Lastly, what are the available values?  Is 0 a higher (or lower) priority than 1?  What about -1000?
Comment 1 Dave Johnson 2012-08-08 14:39:48 EDT
related to bug 828463
Comment 2 Dan Macpherson 2012-08-28 22:11:32 EDT
Modified doc text for Cloud Resource Provider Account creation:

"Type the Priority for your Cloud Resource Provider. This defines to order of priority that CloudForms Cloud Engine utilizes Cloud Resource Providers. Priority is ranked from lowest to highest. For example, a priority of 3 ranks higher than a priority of 5."
Comment 6 Giulio Fidente 2012-10-23 12:35:02 EDT
as per comment from Imre Farkas on bug 864457:

"""
The provider selection during deployment launch has changed a lot since 1.0. In 1.1 we are randomly picking from the set of available provider accounts. The priority attribute is only used for the weight of the random selection.

So you cannot conclude that the provider account with the higher priority will be selected, or the one with the lower priority. Since it's based on random selection it can happen either way.
"""
Comment 8 Lana Brindley 2012-11-18 21:42:54 EST
This documentation has now been dropped to translation ahead of publication. For any further issues, please open a new a bug.

LKB
Comment 9 Lana Brindley 2012-12-10 16:48:55 EST
This document is now publicly available on access.redhat.com. For any further issues, please raise a new bug.

LKB

Note You need to log in before you can comment on or make changes to this bug.