Bug 843814 - Need update of selinux policy related to SSSD
Need update of selinux policy related to SSSD
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
high Severity medium
: rc
: 6.4
Assigned To: Miroslav Grepl
Milos Malik
:
: 848751 (view as bug list)
Depends On: 843730 848751 849567
Blocks: 766000
  Show dependency treegraph
 
Reported: 2012-07-27 08:26 EDT by Jan Zeleny
Modified: 2013-02-21 03:27 EST (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-160.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 843730
Environment:
Last Closed: 2013-02-21 03:27:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Zeleny 2012-07-27 08:26:41 EDT
+++ This bug was initially created as a clone of Bug #843730 +++

In SSSD there is a new feature which writes SSSD config files into /etc/selinux/<policy>/logins/ for SELinux PAM module which then uses this information to set correct context for remote user logging in.

I'd like to ask for update of SELinux policy so SSSD can write into this directory. I've set permissive mode on my machine, tried to log in several times and these are the rules that audit2allow returned:

allow sssd_t selinux_config_t:dir { write remove_name add_name };
allow sssd_t selinux_config_t:file { write rename create unlink };

Please note that we don't write directly to final config files but we rather use mkstemp-style temporary files which are then renamed to the final name.

--- Additional comment from jzeleny@redhat.com on 2012-07-27 10:12:27 CEST ---

There is one mistake in my initial description. SSSD of course writes SELinux config files into /etc/selinux/<policy>/logins/, not SSSD config files.
Comment 1 Miroslav Grepl 2012-08-07 19:43:22 EDT
We added fixes to Fedora. Let's wait to see if this works correctly.
Comment 2 Miroslav Grepl 2012-09-05 01:43:31 EDT
*** Bug 848751 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-09-05 02:56:04 EDT
Backported to RHEL6.4.
Comment 5 Milos Malik 2012-10-30 10:21:30 EDT
# matchpathcon /etc/selinux/targeted/logins//etc/selinux/targeted/logins	system_u:object_r:selinux_login_config_t:s0
# sesearch -s sssd_t -t selinux_login_config_t -c file --allow
Found 1 semantic av rules:
   allow sssd_t selinux_login_config_t : file { ioctl read write create getattr setattr lock append unlink link rename open } ; 

# sesearch -s sssd_t -t selinux_login_config_t -c dir --allow
Found 1 semantic av rules:
   allow sssd_t selinux_login_config_t : dir { ioctl read write getattr lock add_name remove_name search open } ; 

#
Comment 7 errata-xmlrpc 2013-02-21 03:27:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.