Bug 848751 - Need update of selinux policy related to SSSD
Need update of selinux policy related to SSSD
Status: CLOSED DUPLICATE of bug 843814
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On: 843730 849567
Blocks: 766000 843814
  Show dependency treegraph
 
Reported: 2012-08-16 07:06 EDT by Jakub Hrozek
Modified: 2012-11-22 10:36 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 843730
Environment:
Last Closed: 2012-09-05 01:43:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2012-08-16 07:06:06 EDT
+++ This bug was initially created as a clone of Bug #843730 +++

In SSSD there is a new feature which writes SSSD config files into /etc/selinux/<policy>/logins/ for SELinux PAM module which then uses this information to set correct context for remote user logging in.

I'd like to ask for update of SELinux policy so SSSD can write into this directory. I've set permissive mode on my machine, tried to log in several times and these are the rules that audit2allow returned:

allow sssd_t selinux_config_t:dir { write remove_name add_name };
allow sssd_t selinux_config_t:file { write rename create unlink };

Please note that we don't write directly to final config files but we rather use mkstemp-style temporary files which are then renamed to the final name.

--- Additional comment from jzeleny@redhat.com on 2012-07-27 04:12:27 EDT ---

There is one mistake in my initial description. SSSD of course writes SELinux config files into /etc/selinux/<policy>/logins/, not SSSD config files.

--- Additional comment from dwalsh@redhat.com on 2012-07-31 11:59:37 EDT ---

We need a new label for the logins directory and then allowd sssd to write there.

--- Additional comment from mgrepl@redhat.com on 2012-07-31 18:22:16 EDT ---

How about selinux_login_conf_t?

--- Additional comment from dwalsh@redhat.com on 2012-08-01 15:44:11 EDT ---

Fine.

--- Additional comment from mgrepl@redhat.com on 2012-08-07 09:33:19 EDT ---

I have just added fixes. It is going to be in today's build.

--- Additional comment from jhrozek@redhat.com on 2012-08-16 05:20:34 EDT ---

(In reply to comment #5)
> I have just added fixes. It is going to be in today's build.

Miroslav, can you please back port the changes to Fedora 17, too?
Comment 1 Miroslav Grepl 2012-09-05 01:43:31 EDT

*** This bug has been marked as a duplicate of bug 843814 ***

Note You need to log in before you can comment on or make changes to this bug.