Bug 844064 - With encrypted partition on external USB drive, resume (from disk or ram) fails
With encrypted partition on external USB drive, resume (from disk or ram) fails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 844062 844065 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-28 09:46 EDT by William
Modified: 2013-07-31 22:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 22:13:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of fdisk, lvm, pm-suspend.log, lspci (11.46 KB, application/octet-stream)
2012-07-28 09:46 EDT, William
no flags Details

  None (edit)
Description William 2012-07-28 09:46:32 EDT
Created attachment 600927 [details]
Output of fdisk, lvm, pm-suspend.log, lspci

Description of problem:
When going out of suspend to ram (same result with suspend to disk), system hangs, with the following partitionning scheme. On the EXTERNAL USB hard drive:
- /boot is ext4
- the other partition is a container encrypted with luks.
- the decrypted partition is a PV for lvm
- one VG on the PV.
- two LV on the PV: / and swap (>2GB when my ram is 1GB).


Version-Release number of selected component (if applicable):
Not very sure to find which component fails.
Fedora 17 - Kde
Kernel 3.4.6-2

How reproducible:
Every time

Steps to Reproduce:
1. Choose suspend to ram OR pm-suspend
2.
3.
  
Actual results:
System hangs when going out of suspension to ram.
Message: "Read error on /dev/sd*"

Expected results:
Resume desktop

Additional info:
Comment 1 Dave Jones 2012-07-30 09:58:38 EDT
*** Bug 844065 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2012-07-30 10:00:35 EDT
due to the way usb re-enumeration works, this isn't going to be fixed any time soon.
Comment 3 William 2012-07-30 16:50:54 EDT
I used Opensuse and the resume worked from suspend to disk, but I must confess I do not remember for suspend to ram since the Pc I had Acpi problems, but this one shouldn't have some.
I honestly ain't expert enough to find where the trick can be but if you tell me how to extract some logs (I don't know how since the system hangs but I believe I can enable some logging before).
After this feature may not be a priority but if it is just something simple, can be nice.
Thank you
Comment 4 Justin M. Forbes 2012-08-30 14:45:20 EDT
*** Bug 844062 has been marked as a duplicate of this bug. ***
Comment 5 Fedora End Of Life 2013-07-03 19:29:37 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2013-07-31 22:14:04 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.