Bug 84408 - RFE: add i8kutils
RFE: add i8kutils
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
http://people.debian.org/~dz/i8k/
: FutureFeature
: 91671 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-15 20:41 EST by Aleksey Nogin
Modified: 2014-03-16 22:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 15:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2003-02-15 20:41:24 EST
This package contains a user-space programs that can interact with the i8k
module (already included in the kernel starting at least in 8.0) for accessing
the SMM BIOS of Dell Inspiron and Latitude laptops. The SMM BIOS is used on
many recent laptops to implement APM functionalities and to access custom
hardware, for example the cooling fans and volume buttons.

The package include also the following utilities:

    * i8kctl	 - interface to the kernel driver

    * i8kmon	 - temperature monitor with automatic or manual fan control

    * i8kbuttons - monitors volume buttons and runs user-defined commands

See also http://people.debian.org/~dz/i8k/00-README and
http://rpmfind.net/linux/rpm2html/search.php?query=i8kutils
Comment 1 Alan Cox 2004-06-21 11:26:14 EDT
*** Bug 91671 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Saou 2004-07-22 14:23:28 EDT
My packages can be found at the rpmfind.net URL above, they even
contain an init script that takes care of enabling the daemon for the
buttons to be functionnal, so they could serve as a base for a package
to be included.

Nevertheless, I think this kind of package, which targets a very
specific audience (Dell laptop owners, only for a few models) should
probably be something for Fedora Extras. WONTFIX? :-)
Comment 3 Bill Nottingham 2004-07-22 15:04:39 EDT
Agreed.

Note You need to log in before you can comment on or make changes to this bug.