Bug 844334 - PDF printing delayed from Evince
PDF printing delayed from Evince
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 06:36 EDT by Antonio Trande
Modified: 2012-10-18 06:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 06:19:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PDF file (272.79 KB, application/pdf)
2012-07-30 11:54 EDT, Antonio Trande
no flags Details
first page as printed to pdf from evince (499.77 KB, application/pdf)
2012-08-02 11:14 EDT, Jiri Popelka
no flags Details

  None (edit)
Description Antonio Trande 2012-07-30 06:36:07 EDT
Description of problem:
PDF document printing from Evince is very slow. Once printing job starts, 'pdftops' process appears on 'htop' with a CPU usage very high per about 2 minutes after which the printer starts to work.

Version-Release number of selected component (if applicable):
cups-1.5.2-12.fc17
Printer: Canon PIXMA MP270 - CUPS + Gutenprint v5.2.9 Simplified


How reproducible:
Open pdf file with Evince, launch a print, printer works after about 2 minutes.


Actual results:
Printing job delayed.

Expected results:
Immediate printer response.

Additional info:
Suspicion link with #Bug827632, #Bug828301
Comment 1 Jiri Popelka 2012-07-30 07:37:20 EDT
Does it behave the same when you print the file with 'lpr file.pdf' ?
Is it the same with all pdf files ?
Is printing of postscript file (so pdftops is not involved) OK ?

I don't think bug #827632 and bug #828301 are related because they are about not printing at all and also when using foomatic driver (you use gutenprint).
Comment 2 Antonio Trande 2012-07-30 10:04:14 EDT
(In reply to comment #1)
> Does it behave the same when you print the file with 'lpr file.pdf' ?

No.

> Is it the same with all pdf files ?

No. I can tell you that the file is a PDF ver1.4 .
I have just tried another (ver1.5) and it is printed fine with Evince.

> Is printing of postscript file (so pdftops is not involved) OK ?

Yes.
Comment 3 Jiri Popelka 2012-07-30 10:30:39 EDT
Can you attach an output from printing troubleshooter when printing that file from Evince ?
https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter
Comment 4 Jiri Popelka 2012-07-30 10:32:14 EDT
Actually it would be useful if you could attach that pdf file too.
You can make the attachment private if you want.
Comment 5 Antonio Trande 2012-07-30 11:52:56 EDT
(In reply to comment #3)
> Can you attach an output from printing troubleshooter when printing that
> file from Evince ?
> https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter

/var/log/cups/error_log is empty.

>Actually it would be useful if you could attach that pdf file too.
>You can make the attachment private if you want.

Sure. I can tell you more: this problem appears if print the single first page, not with the others.
Comment 6 Antonio Trande 2012-07-30 11:54:03 EDT
Created attachment 601304 [details]
PDF file
Comment 7 Jiri Popelka 2012-08-02 11:14:06 EDT
Created attachment 601981 [details]
first page as printed to pdf from evince
Comment 8 Jiri Popelka 2012-08-02 11:19:24 EDT
This seems to be a poppler.

If I open the document from comment #6 in evince and print the first page to PDF, then the result makes pdftops and also okular (which I think also uses poppler) eat a lot of CPU.

Note You need to log in before you can comment on or make changes to this bug.