Bug 844504 - FTBFS in Rawhide with gphoto 2.5.0
FTBFS in Rawhide with gphoto 2.5.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-07-30 19:19 EDT by Adam Williamson
Modified: 2015-03-03 18:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-10 13:57:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-07-30 19:19:43 EDT
gvfs has failed to build ever since Rawhide bumped to gphoto2 2.5.0. Reported upstream at https://bugzilla.gnome.org/show_bug.cgi?id=680871 , but duplicating downstream as this is a potential F18 Alpha blocker - it'll block compose of the F18 Alpha images unless we drop shotwell from the default packages, because the failure to rebuild gvfs makes shotwell un-installable in Rawhide at present:

Error creating Live CD : Failed to build transaction : shotwell-0.12.3-1.fc18.x86_64 requires libgphoto2.so.2()(64bit)
gvfs-gphoto2-1.13.2-1.fc18.x86_64 requires libgphoto2_port.so.0()(64bit)
gvfs-gphoto2-1.13.2-1.fc18.x86_64 requires libgphoto2.so.2()(64bit)
shotwell-0.12.3-1.fc18.x86_64 requires libgphoto2_port.so.0()(64bit)
Comment 1 Adam Williamson 2012-07-30 19:46:49 EDT
Actually, I think I mis-diagnosed that - shotwell doesn't depend on gvfs-gphoto2, they're just coincidentally both broken in the same way (by the gphoto2 API change). the shotwell issue should be a separate bug. The gvfs breakage is still important, of course.
Comment 2 Adam Williamson 2012-08-03 19:49:48 EDT
Discussed at the blocker bug review meeting of 2012-08-03: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-08-03/f18-alpha-blocker-review-1.2012-08-03-17.01.log.html .

Accepted as a blocker as it violates criterion "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install" (unresolved deps), and would also break live image compose entirely.

Our options here, in descending order of desirability but probably ascending order of ease, are:

1) Patch the code to build against 2.5.0
2) Ship a gphoto2-compat package
3) Drop gvfs-gphoto2 from spins and the DVD until 1) or 2) is done
Comment 3 Adam Williamson 2012-08-07 17:17:56 EDT
Point 3) should obviously read 'Drop shotwell from spins...'.
Comment 4 Adam Williamson 2012-08-10 13:57:21 EDT
actually, it shouldn't. This is the bug for gvfs. jnovy actually fixed gvfs, but then closed 844510 - which is the bug for shotwell - instead of this bug.

So, I'm closing this bug - see https://bugzilla.redhat.com/show_bug.cgi?id=844510#c5 . I have re-opened 844510, for shotwell.

Note You need to log in before you can comment on or make changes to this bug.