Bug 844510 - FTBFS in Rawhide with gphoto 2.5.0
FTBFS in Rawhide with gphoto 2.5.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shotwell (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Matthias Clasen
Dan Mashal
AcceptedBlocker
: Reopened
: 847694 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-07-30 20:12 EDT by Adam Williamson
Modified: 2012-08-27 21:31 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 21:31:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-07-30 20:12:05 EDT
As reported upstream at http://redmine.yorba.org/issues/5553 , Shotwell fails to build against gphoto 2.5.0 which is present in Rawhide. This is a potential F18 Alpha blocker as Shotwell is on the DVD and live images but is currently dep-broken, which is why I'm filing a downstream report. We would either have to get a fix for this, revert gphoto2 or drop Shotwell from the live image and DVD to get a working F18 compose.
Comment 1 Thomas Moschny 2012-07-31 06:05:35 EDT
Would it be possible to get get a libgphoto2-compat package into F18?
Comment 2 Adam Williamson 2012-08-03 19:50:02 EDT
Discussed at the blocker bug review meeting of 2012-08-03: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-08-03/f18-alpha-blocker-review-1.2012-08-03-17.01.log.html .

Accepted as a blocker as it violates criterion "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install" (unresolved deps), and would also break live image compose entirely.

Our options here, in descending order of desirability but probably ascending order of ease, are:

1) Patch the code to build against 2.5.0
2) Ship a gphoto2-compat package
3) Drop gvfs-gphoto2 from spins and the DVD until 1) or 2) is done
Comment 3 Jindrich Novy 2012-08-06 07:38:39 EDT
I added a patch that fixes gvfs's build againtst libgphoto2 and allows to build it also against the old one. The problem is that the build fails because of a different reason, i.e. it tries to download some documentation over web during build:

http://koji.fedoraproject.org/koji/getfile?taskID=4360341&name=build.log

So I think 1) is the way to go. I'm currently on it as gvfs's maintainer seems to be on PTO.

Shotwell is a different case. There is needed to change Vala calls to conform to the latest libgphoto2 API. Thomas Moschny is looking into it.
Comment 4 Adam Williamson 2012-08-06 23:29:23 EDT
There's a separate bug for shotwell, so no need to discuss it here. Thanks for the patch!
Comment 5 Jindrich Novy 2012-08-07 00:56:21 EDT
Fixed in rawhide, gvfs is now built against libgphoto2 2.5.0.
Comment 6 Adam Williamson 2012-08-10 13:55:44 EDT
jnovy: ah. Um, turns out you rather screwed things up: this was the bug for *shotwell*. 844504 was for gvfs. But you changed this to be against gvfs and closed it...(I did accidentally put the wrong package name in comment #2, sorry).

So, re-opening this as it's for *shotwell*. Re-pasting comment #2 correctly for clarification. I will close 844504, as gvfs has been fixed.
Comment 7 Adam Williamson 2012-08-10 13:56:06 EDT
Our options here, in descending order of desirability but probably ascending order of ease, are:

1) Patch the code to build against 2.5.0
2) Ship a gphoto2-compat package
3) Drop shotwell from spins and the DVD until 1) or 2) is done
Comment 8 Colin Walters 2012-08-15 12:18:13 EDT
Upstream issue:

http://redmine.yorba.org/issues/5553
Comment 9 Adam Williamson 2012-08-16 15:17:09 EDT
Discussed at 2012-08-16 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-08-16/f18-alpha-blocker-review-3.2012-08-16-16.00.html . We agreed there's little we can do here, just follow the upstream work, and block shotwell from composes if it's not fixed in time.
Comment 10 Fedora Update System 2012-08-21 03:55:50 EDT
shotwell-0.12.3-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/shotwell-0.12.3-5.fc18
Comment 11 Fedora Update System 2012-08-21 13:07:52 EDT
Package shotwell-0.12.3-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing shotwell-0.12.3-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12406/shotwell-0.12.3-5.fc18
then log in and leave karma (feedback).
Comment 12 Adam Williamson 2012-08-22 14:06:27 EDT
*** Bug 847694 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2012-08-27 21:31:51 EDT
shotwell-0.12.3-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.