Bug 844538 - removing PyXML -- need to port openxcap
removing PyXML -- need to port openxcap
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openxcap (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843176
  Show dependency treegraph
 
Reported: 2012-07-30 23:10 EDT by Toshio Ernie Kuratomi
Modified: 2012-09-17 19:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:23:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2012-07-30 23:10:43 EDT
Description of problem:

We're trying to remove PyXML from Fedora 18 if we can because it is dead upstream and the Python stdlib has the dubious behaviour of overwriting its own xml module with code from PyXML if PyXML is installed.  The combination of these has caused problems for other code that wants to use the stdlib xml module but is getting older, buggy code from PyXML instead.

https://fedoraproject.org/wiki/User:Toshio/Remove_PyXML

I've taken a look at openxcap and found that it has a real dependency on PyXML
./xcap/element.py  uses a feature of the PyXML sax library that isn't available in the stdlib's version: 

    parser.setFeature(sax.handler.feature_namespace_prefixes, 1)

Some questions:
* Is there any interest from upstream (or you) in porting away from PyXML?
* openxcap doesn't appear to be used by anything in Fedora.  If PyXML is removed and openxcap doesn't get ported to something else, would the removal of openxcap as well cause any issues?
Comment 1 Fedora Update System 2012-08-18 11:01:57 EDT
openxcap-2.0.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openxcap-2.0.1-1.fc18
Comment 2 Fedora Update System 2012-08-18 14:49:43 EDT
Package openxcap-2.0.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openxcap-2.0.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12192/openxcap-2.0.1-1.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-09-17 19:23:50 EDT
openxcap-2.0.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.