Bug 844545 - Can we port libopensync-plugin-google-calendar away from PyXML?
Can we port libopensync-plugin-google-calendar away from PyXML?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libopensync-plugin-google-calendar (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843176
  Show dependency treegraph
 
Reported: 2012-07-30 23:20 EDT by Toshio Ernie Kuratomi
Modified: 2013-02-07 10:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 10:40:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2012-07-30 23:20:16 EDT
Description of problem:
We're looking at removing PyXML from Fedora 18 because it is long dead upstream and it has the unfortunate behaviour of replacing the stdlib's xml module with its own if it is installed.  This leads to code which expects the stdlib's xml module to get PyXML's old, buggy code if PyXML is installed.  https://fedoraproject.org/wiki/User:Toshio/Remove_PyXML

I've had a look at libopensync-plugin-google-calendar and its only use of PyXML appears to be in one line of ./src/google-cal-helper.py where it is using xpath to """Return value of first element matching xpath expression""".  Could either the upstream or we port the code to use a different library to evaluate the xpath expression?
Comment 1 Toshio Ernie Kuratomi 2013-01-11 14:52:52 EST
Hey, I've opened a F19 feature to remove PyXML.  Not sure what we want to do with this package.  Are you still interested in it?  If you need assistance, I can assist in porting this package but I have no idea what it does so I can't do it alone.  If you aren't interested in it anymore, I can retire and block it from F19.

If I don't hear back from you I'll go ahead and retire it after FUDCon (~ 2 weeks from now).
Comment 2 Toshio Ernie Kuratomi 2013-02-07 10:40:13 EST
Retired in rawhide

Note You need to log in before you can comment on or make changes to this bug.