Bug 844547 - comoonics-base-py, comoonics-cdsl-py, comoonics-cluster-py
comoonics-base-py, comoonics-cdsl-py, comoonics-cluster-py
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comoonics-base-py (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc Grimme
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 843176
  Show dependency treegraph
 
Reported: 2012-07-30 23:32 EDT by Toshio Ernie Kuratomi
Modified: 2013-02-07 10:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 10:33:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Ernie Kuratomi 2012-07-30 23:32:32 EDT
Description of problem:

We're trying to get rid of the PyXML package for Fedora 18.  This is because it has been long dead upstream and it has the dubious behaviour of replacing the xml module from the stdlib with its code if it is installed.  This causes other applications and libraries that depend on the xml library in the stdlib to fail when PyXML is installed (and they get PyXML's older, buggy code.)

I've taken a look at the three comoonics packages: comoonics-base-py, comoonics-cdsl-py, and comoonics-cluster-py.  It looks like the packages use the PyXML extensions to the stdlib xml library quite extensively.  Notably, PyXML has an xpath subpackage but the stdlib xml library does not.

Is there any work from upstream to port this library away from PyXML to something else (For instance, lxml)?  Due to the extensive use of PyXML, I don't see any other way but to port to get rid of PyXML and still have comoonics work in Fedora.  Thoughts?
Comment 1 Toshio Ernie Kuratomi 2013-01-11 14:56:32 EST
Hi,  haven't heard anything from you about this and wondered if you had any thoughts.  I've opened a Fedora 19 Feature to remove PyXML from the distribution.  I see that comoonics* hasn't been built by you since 2009.  Are you still interested in these packages in Fedora?  If not, I think we should retire them (and their dependency, osr-dracut-module) in F19.

If I don't hear back from you I'll go ahead and do that after FUDCon (about 2 weeks from now).
Comment 2 Toshio Ernie Kuratomi 2013-02-07 10:33:49 EST
Retired in rawhide.

Note You need to log in before you can comment on or make changes to this bug.