Bug 844609 - Django will generate default password like "}!v,PQ}BEn" which can not log the default user in.
Django will generate default password like "}!v,PQ}BEn" which can not log the...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: N. Harrison Ripps
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 03:39 EDT by Yujie Zhang
Modified: 2015-05-14 22:02 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhc-0.96.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-07-31 03:39:36 EDT
Description of problem:

After I git push django, sometimes it will generate default password like "}!v,PQ}BEn" , the default user can not log in use this password.

Version-Release number of selected component (if applicable):

devenv_1922

How reproducible:

randomly

Steps to Reproduce:
1.Create a Django app following the quick start directions at https://github.com/openshift/django-example/blob/master/README.md 
2.Log into Django admin UI using generated admin password.
3.
  
Actual results:

Sometimes it will generate default password like "}!v,PQ}BEn" which can not log default use in.There is always remind message like "Please enter the correct username and password for a staff account. Note that both fields are case-sensitive."

Expected results:
The default should always be able to log the default user in.

Additional info:
Comment 1 N. Harrison Ripps 2012-07-31 11:28:13 EDT
I have gone back and found the set of characters that are legal to use in passwords. Pull request pending.
Comment 2 N. Harrison Ripps 2012-07-31 12:55:35 EDT
*** Bug 844537 has been marked as a duplicate of this bug. ***
Comment 3 N. Harrison Ripps 2012-08-01 11:34:30 EDT
The pull request is in, so this fix will be immediately available.
Comment 4 Chandrika Gole 2012-08-01 19:57:24 EDT
Tried this 3 times and each time a valid password was generated each time

Note You need to log in before you can comment on or make changes to this bug.