Bug 844688 - improvements in statedumps
improvements in statedumps
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Raghavendra Bhat
Sachidananda Urs
:
Depends On:
Blocks: 844802 857308
  Show dependency treegraph
 
Reported: 2012-07-31 08:05 EDT by Raghavendra Bhat
Modified: 2013-09-23 18:32 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 844802 857308 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:32:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2012-07-31 08:05:46 EDT
Description of problem:

Statedumps of the glusterfs processes need to be improved, such as a start and end marker should be added in the statedump files which indicates beginning and end of the statedump information. Apart from that in statedumps gf_log should not be used and instead of pthread_mutex_lock, pthread_mutex_trylock should be used to avoid deadlocks.

Also the names of the statedump files should be changed by appending the timestamp the filename. Otherwise of statedump is issued on the same glusterfs process again, then the old statedump information is lost.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Sachidananda Urs 2013-01-08 07:07:31 EST
Gluster dump generated by sosreport now has the start and end markers. And the generated files are named by appending the timestamps to the file.

After extracting the sosreport archive, the files can be found under:  sos_commands/gluster/glusterfs-statedumps

The generated dump file look like: exports-840811.14584.dump.1357565301  exports-dist.27134.dump.1357565301  glusterdump.19754.dump.1357565301
exports-848327.16771.dump.1357565301  glusterdump.16787.dump.1357565301

And the header and footer contains the strings:
DUMP-START-TIME: 2013-01-07 13:28:21.862228 and DUMP-END-TIME: 2013-01-07 13:28:21.879735 respectively which will help us determine if the dump contains all the data from the process.
Comment 3 Vijay Bellur 2013-02-06 15:19:12 EST
CHANGE: http://review.gluster.org/4087 (libglusterfs/core: dump frame and callstack creation times in statedump) merged in master by Anand Avati (avati@redhat.com)
Comment 4 Scott Haines 2013-09-23 18:32:56 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.