Bug 844802 - improvements in statedumps
improvements in statedumps
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Raghavendra Bhat
Sachidananda Urs
:
Depends On: 844688 849546 849601 851109 851410 857308 866859 964331
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 16:24 EDT by Scott Haines
Modified: 2015-01-22 10:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 844688
Environment:
Last Closed: 2012-09-11 10:23:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Sachidananda Urs 2012-08-20 01:10:27 EDT
Any writeup on what improvements are done?
Comment 2 Amar Tumballi 2012-09-05 07:09:16 EDT
Need to test below for statedump changes:

* One of the main fix was to make sure no 'deadlock' has happened while taking statedump. Can be tested by issuing SIGUSR1 signal continuously on the process and it should not hang.

* Timestamp added to the name of the dump file
* 'Begin' and 'End' markers added to statedump file, helps to make sure the file is completely dumped before copying.

* The statedump file generated from 'sosreport' should not have all the inode information instead should only have inode data, for which there is a lock held [patch still in review as i write this comment]
Comment 3 Amar Tumballi 2012-09-10 12:20:39 EDT
patch pushed to downstream.
Comment 4 Sachidananda Urs 2012-09-11 01:33:37 EDT
Works on distribute, continuing tests on distributed replicate.
Comment 6 errata-xmlrpc 2012-09-11 10:23:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1253.html

Note You need to log in before you can comment on or make changes to this bug.