Bug 844924 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'write' accesses on the directory .gstreamer-0.10.
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'write' accesses ...
Status: CLOSED DUPLICATE of bug 844322
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d7a44e394c412974f0fced33206...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 05:36 EDT by mamii
Modified: 2012-08-01 11:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 11:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mamii 2012-08-01 05:36:33 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.x86_64
time:           Wed 01 Aug 2012 10:36:15 AM CET

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from 'write' accesses on the directory .gstreamer-0.10.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that totem-video-thumbnailer should be allowed write access on the .gstreamer-0.10 directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:admin_home_t:s0
:Target Objects                .gstreamer-0.10 [ dir ]
:Source                        totem-video-thu
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-3.4.3-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-1.fc17.x86_64 #1 SMP
:                              Thu Jul 26 21:48:14 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Mon 30 Jul 2012 10:49:24 AM CET
:Last Seen                     Mon 30 Jul 2012 10:49:24 AM CET
:Local ID                      8df6cbdc-8b81-4af1-be1f-ffd0a1fb9dec
:
:Raw Audit Messages
:type=AVC msg=audit(1343641764.106:124): avc:  denied  { write } for  pid=7729 comm="totem-video-thu" name=".gstreamer-0.10" dev="dm-2" ino=1046678 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1343641764.106:124): avc:  denied  { add_name } for  pid=7729 comm="totem-video-thu" name="registry.x86_64.bin.tmpMEHBIW" scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1343641764.106:124): avc:  denied  { create } for  pid=7729 comm="totem-video-thu" name="registry.x86_64.bin.tmpMEHBIW" scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=AVC msg=audit(1343641764.106:124): avc:  denied  { write } for  pid=7729 comm="totem-video-thu" path="/root/.gstreamer-0.10/registry.x86_64.bin.tmpMEHBIW" dev="dm-2" ino=1046679 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1343641764.106:124): arch=x86_64 syscall=open success=yes exit=ESRCH a0=1e404e0 a1=c2 a2=180 a3=1 items=0 ppid=7270 pid=7729 auid=1000 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=2 comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-video-thu,thumb_t,admin_home_t,dir,write
:
:audit2allow
:
:#============= thumb_t ==============
:#!!!! The source type 'thumb_t' can write to a 'dir' of the following types:
:# xdm_tmp_t, gstreamer_home_t, user_home_dir_t, thumb_tmp_t, tmp_t, user_tmp_t, thumb_home_t
:
:allow thumb_t admin_home_t:dir { write add_name };
:allow thumb_t admin_home_t:file { write create };
:
:audit2allow -R
:
:#============= thumb_t ==============
:#!!!! The source type 'thumb_t' can write to a 'dir' of the following types:
:# xdm_tmp_t, gstreamer_home_t, user_home_dir_t, thumb_tmp_t, tmp_t, user_tmp_t, thumb_home_t
:
:allow thumb_t admin_home_t:dir { write add_name };
:allow thumb_t admin_home_t:file { write create };
:
Comment 1 Miroslav Grepl 2012-08-01 11:26:56 EDT

*** This bug has been marked as a duplicate of bug 844322 ***

Note You need to log in before you can comment on or make changes to this bug.